Text Overlaping Issue in Firefox

Discussion in 'Mac Basics and Help' started by Verdanice, Sep 7, 2007.

  1. Verdanice macrumors regular

    Joined:
    Aug 13, 2007
    #1
    Hi,

    I bought a Macbook Pro 2.4/2GB/160GB about a week ago and installed everything I needed immediately this is my first Mac, but I've been working on them at work for over a year). Those installations included Firefox, of course. Everything was fine for a few days, but within the past couple days a problem has come up with font rendering in Firefox. Text overlaps all over the place - spacing will disappear, words will collide with each other and typing in some text inputs is disastrous. Here are a couple examples of what I mean:

    [​IMG]

    [​IMG]

    The Digg comment box above is the largest issue. Also, text will not wrap properly - leaving the page to the right when the page is fluid width. these issues came around suddenly, they definitely weren't a problem before a couple days ago.

    Any idea what could be going wrong? I've tried changing Firefox's default font from Times to Arial, that didn't do anything.

    Your help is apreciated!

    Thanks in advance,
    Gavin
     
  2. smurfy macrumors member

    Joined:
    Aug 6, 2007
    #2
    Unfortunately there are alot of issues with Firefox for Mac - I personally have experienced permanent text cursor, text cursor staying on screen when you switch tabs, Flash not working properly, QuickTime not working at all, and AdBlock Plus missing Flash block tabs.
     
  3. bousozoku Moderator emeritus

    Joined:
    Jun 25, 2002
    Location:
    Gone but not forgotten.
    #3
    I've only seen the overlapping text a few time with certain websites after they've apparently revised their layout. I haven't found a fix for it, but you should report it to Mozilla: Help menu->Report Broken Web Site...

    If it helps, version 3 has almost flawless rendering.
     
  4. angelwatt Moderator emeritus

    angelwatt

    Joined:
    Aug 16, 2005
    Location:
    USA
    #4
    I've had that problem on Mac and Windows from time to time. It usually fixed itself after a little while. Some times a reboot will fix it. It was never clear what caused it, but never lasted long and only has happened a small number of times.
     
  5. netnothing macrumors 68040

    netnothing

    Joined:
    Mar 13, 2007
    Location:
    NH
    #5
    Have you checked for duplicate fonts in Font Book?

    -Kevin
     
  6. netnothing macrumors 68040

    netnothing

    Joined:
    Mar 13, 2007
    Location:
    NH
    #6
    Also you can try emptying your users font cache.

    It's in a folder on the main HD -> Library -> Caches -> com.apple.ATS

    Your user folder is a numbered folder in that directory...usually 501.

    Empty everything in that folder, reboot and see if it fixes the problem.

    -Kevin
     
  7. Verdanice thread starter macrumors regular

    Joined:
    Aug 13, 2007
    #7
    I cleared the font cache and I've restarted a few times since this started happening, those didn't fly. Thanks for your suggestions, guys.

    kbmb, is there an automated way to check for duplicates? I have a load of fonts installed and their names sometimes vary only slightly.

    Thanks or your help so far!
     
  8. netnothing macrumors 68040

    netnothing

    Joined:
    Mar 13, 2007
    Location:
    NH
    #8
    Open Font Book and make sure you seeing the list of all the fonts. In the font list, highlight one, then click Command + A to select all the fonts. Then you can run the Validate Fonts option from the menu (not on my Mac now so can't remember which menu).

    That will pop up a window that will refresh as it validates all fonts.

    -Kevin

    EDIT: Ok...I'm slow tonight. Select the menu item to resolve duplicates.
     
  9. Verdanice thread starter macrumors regular

    Joined:
    Aug 13, 2007
  10. Fearless Leader macrumors 68020

    Joined:
    Mar 21, 2006
    Location:
    Hoosiertown
    #10
    I had the same issue running leopard, its gone away with the newer releases though.
     
  11. Verdanice thread starter macrumors regular

    Joined:
    Aug 13, 2007
    #11
    The latest nightly build of Firefox for OSX didn't fix it either. Weird.
     
  12. earthairfire macrumors newbie

    Joined:
    Sep 20, 2007
    #12
    I fixed it by changing the default font to tahoma, and in advanced options disallowing websites from choosing their own fonts.

    Hope it helps!

    Tim
     
  13. netnothing macrumors 68040

    netnothing

    Joined:
    Mar 13, 2007
    Location:
    NH
    #13
    Wouldn't really call that a 'fix'. Now you'll see every site with the same font, possibly breaking the original site's design by not using the font the developer intended.

    -Kevin
     
  14. 2Shae macrumors 6502

    Joined:
    Sep 7, 2006
    #14
    have the same problem...even have my on thread on here about it.

    It made me switch to Safari.
     

Share This Page