Text Replacement Sync Issues

Discussion in 'iOS 10' started by RMSko, Sep 18, 2016.

  1. RMSko macrumors 6502

    Joined:
    Sep 3, 2010
    #1
    I've had very strange behavior with my text replacements after updating to iOS 10.

    - On my iPhone 6 Plus, iPad Pro and iPad Air, all text replacements disappeared after updating. I've done all the recommended steps (turn off iCloud etc), but nothing worked. As a result, I added all the shortcuts onto my iPhone, but they did not sync to either iPad.

    - I added some shortcuts to my iPad Pro and those did sync to my iPad Air, but they did NOT sync to my iPhone 6 Plus.

    - I got a new iPhone 7 Plus and after setting that up, all my ORIGINAL text replacements appeared, i.e., not the text replacements from either my iPhone 6 Plus or the iPads, but the original text replacements that I thought were lost, but I guess were in the cloud.

    This is clearly and iOS 10 upgrade issue, but it's very strange. Anyone have any thoughts on what I can try to get the iCloud text replacements synced to the other devices (again, I've already tried all the standard tips like turning off iCloud, logging out of my iCloud account and restarting)?
     
  2. stooovie macrumors 6502a

    Joined:
    Nov 21, 2010
    #2
    It's never ever been even close to reliable on my devices. I've got them appearing, reappearing, disappearing or not syncing at all... All the other iCloud stuff syncs just fine. Not this.

    There's nothing you can do about this.
     
  3. RMSko, Sep 18, 2016
    Last edited: Sep 18, 2016

    RMSko thread starter macrumors 6502

    Joined:
    Sep 3, 2010
    #3
    BTW - turning iCloud Drive off and on with my Mac, did bring the text shortcuts back to my Mac so it syncs with some devices, but not all devices. Also, the shortcuts suddenly appeared on my iPad Air, but not my iPad Pro so I have no idea what's going on.
     
  4. Yptcn macrumors 6502a

    Yptcn

    Joined:
    Aug 24, 2012
    Location:
    Paris
    #4
    I opened a tread about that a few days ago :
    http://forums.macrumors.com/threads/ios-10-text-replacements-gone.1995279/

    Here is a copy/paste of something that seems to have worked for me :


    Swiched iCloud Drive off.

    Hard reboot .

    Wait 5 minutes.

    Turned iCloud Drive back on.

    Hard reboot.

    Wait 5 minutes.


    Then I checked the Text Replacements ...and they were back !


    I don't know if it's a fix or not , or if they were just ready to come back but it's worth trying out .


    I would really like to know if this helped someone or not... Just in case it happens again .
     
  5. RMSko thread starter macrumors 6502

    Joined:
    Sep 3, 2010
    #5
    Unfortunately this didn't work for me
     
  6. jagooch macrumors regular

    jagooch

    Joined:
    Jul 17, 2009
    Location:
    Denver, co
    #6
     
  7. stooovie macrumors 6502a

    Joined:
    Nov 21, 2010
    #7
    Yeah, the obligatory iCloud dance. It "fixes" some stuff sometimes, but it's a wild guess.
     
  8. Pagemakers macrumors 68020

    Pagemakers

    Joined:
    Mar 28, 2008
    Location:
    Manchester UK
    #8
    OMG - here we are with iOS 11 and still text replacement doesn’t sync across devices.

    I’ve probably spent 20 hours this year with Apple Technical Support and here we are a full 12 months and a new OS later and still the stupid things don’t sync. How bloody hard can it be?
     

Share This Page