Text Wrangler 4 update

Discussion in 'Mac Programming' started by Hylekmi, Apr 11, 2012.

  1. Hylekmi macrumors regular

    Dec 8, 2010
    I Updated last night and now i can't compile java. Everytime I go to run it i get an error. I attached the error message(i think). I tried to do a fresh install, deleting the scripts folder and re adding the scripts. Still doesn't work. Any tips?

    Attached Files:

  2. SubsidedProdigy, Apr 12, 2012
    Last edited: Apr 12, 2012

    SubsidedProdigy macrumors newbie

    Jul 22, 2011
    I'm also having this issue. It has something to do with the bolded line but I have no idea how to fix it. Hopefully someone has a solution?
    Here's the compiling script I'm using.

    tell application "TextWrangler"
    save text document 1
    set the_file to file of text document 1
    end tell

    set AppleScript's text item delimiters to ":"
    set source_file to the last text item of (the_file as string)

    tell application "Finder"
    set the_folder to container of the_file as alias
    end tell

    tell application "Terminal"
    set shell_script to "cd " & (quoted form of POSIX path of the_folder) & ¬
    "; javac " & source_file
    if (count windows) is 0 then
    do script shell_script
    do script shell_script in the front window
    end if
    end tell

    Update: Found a quick fix for now. Just uninstall TextWrangler 4.0 and reinstall the previous version
    Here's a link: http://www.barebones.com/support/textwrangler/updates.html
  3. Hylekmi thread starter macrumors regular

    Dec 8, 2010
    I took my macbook pro to the apple store and it turns out they switched it out. I haven't tried to install text wrangler yet though but if i get the same issue(i don't think i will) then i will try that. Thanks!

Share This Page