TextEdit Error Message

gremsi26

macrumors newbie
Original poster
Sep 3, 2008
10
0
When text edit tries to auto save, it displays this message:
This Document Could not be autosaved because you don't have write access privileges to the folder that it's in.​

I am logged as an administrator, and I'm running snow leopard. I have already tried repairing disk permissions through disk utility and that did not work. Does anyone know a fix to this problem? Thanks in advance
 

gremsi26

macrumors newbie
Original poster
Sep 3, 2008
10
0
Its trying to save a .rtf file. For the location, I googled where TextEdit would auto-save but had no luck.
 

Darth.Titan

macrumors 68030
Oct 31, 2007
2,740
451
Austin, TX
Do a manual save to your Documents folder and autosave should save there from now on. If it's a new document it may be trying to autosave in some temp directory that you do not have permissions for.

A permissions repair might be in order as well.
 

gremsi26

macrumors newbie
Original poster
Sep 3, 2008
10
0
Do a manual save to your Documents folder and autosave should save there from now on. If it's a new document it may be trying to autosave in some temp directory that you do not have permissions for.

A permissions repair might be in order as well.
That seems to work (to manually save); however, this error didn't pop up a couple of weeks ago, so im guessing something went wrong. Is there a fix to this without manually saving it first?

I tried a permissions repair and it did not fix the problem. I could be wrong but, shouldn't i have permissions since I'm the administrator and the only user on this computer?
 

mysterytramp

macrumors 65816
Jul 17, 2008
1,334
3
Maryland
There aren't many, but there are folders that even an administrator doesn't have permission to enter. If you go on an expedition through your System folders, you'll find a few.

If you're curious, this should work:

Do a Get Info on a blocked folder.
Click the lock icon in the lower right corner. It will ask you for your password.
Once unlocked, set the permissions for "everyone" to Read Only.

mt
 

gremsi26

macrumors newbie
Original poster
Sep 3, 2008
10
0
There aren't many, but there are folders that even an administrator doesn't have permission to enter. If you go on an expedition through your System folders, you'll find a few.

If you're curious, this should work:

Do a Get Info on a blocked folder.
Click the lock icon in the lower right corner. It will ask you for your password.
Once unlocked, set the permissions for "everyone" to Read Only.

mt
Oh, i didnt know abt that. So is there a specific folder where text edit auto saves, so i can set the permissions to everyone?
 

wrldwzrd89

macrumors G5
Jun 6, 2003
12,107
75
Solon, OH
No. TextEdit's auto-save behavior works like this:

If you open a document, the auto-saved copy goes into the same folder as the original document. If you create a new document, and don't save it for a while, the auto-saved version ends up in a temporary folder. In both cases, the temp file is deleted when the file is saved by you.
 

brkirch

macrumors regular
Oct 18, 2001
191
1
In case anyone is still looking for a solution to this problem, try going to home folder > Library and deleting the "Autosave Information" folder, that should fix the problem.
 

gremsi26

macrumors newbie
Original poster
Sep 3, 2008
10
0
The problem disappeared because I reinstalled Snow Leopard (not because of this problem), but if it pops up again, ill try this out. Thanks.

In case anyone is still looking for a solution to this problem, try going to home folder > Library and deleting the "Autosave Information" folder, that should fix the problem.
 

gballey

macrumors newbie
May 8, 2009
4
0
In case anyone is still looking for a solution to this problem, try going to home folder > Library and deleting the "Autosave Information" folder, that should fix the problem.
Thanks! I've been having the exact same problem with TextEdit that the original poster described since about the time I upgraded to Snow Leopard from 10.5.8. After opening a new TextEdit document, I'd start getting these periodic error messages until I saved it manually or closed it. It happened again a few minutes ago, which prompted me to Google the error message, and the first link directed me here.

When I just now checked the Autosave Information folder for my "default" user, gordon, I saw that the folder's permissions were set as:

system: Read & Write
everyone: No Access

And its folder icon had the international do-not-enter symbol on it (even though this user has had administrator privileges for the past several weeks). I just checked my standby user's (gordon2) Autosave Information folder, and its permissions are set to

gordon2: Read& Write
staff: Read only
everyone: Read only

I don't know why these are set differently. I don't recall ever manually fiddling with the permissions on these folders.

I added gordon as an additional permissions class with Read & Write permissions to the problem folder. I then opened the folder, and it was empty. A short time later, the autosaved copy of my TextEdit document appeared in the folder, along with a TextEdit plist file. And I haven't seen another error message.

I believe this started about the time of my upgrade to OS X 10.6 from 10.5.8. Macaroni automatically repairs permissions every week, so I doubt a manual repair would have fixed it.

Thanks again for directing my attention to that folder.

-Gordon
 

greenprell

macrumors newbie
Feb 3, 2010
1
0
In case anyone is still looking for a solution to this problem, try going to home folder > Library and deleting the "Autosave Information" folder, that should fix the problem.
This solution worked GREAT. The folder was recreated by TextEdit, and the autosaving worked.

I agree with others that this seems to have been introduced by Snow Leopard.

You learn something new every day! Thanks!!
 

lairdo

macrumors newbie
Sep 27, 2008
18
15
I added gordon as an additional permissions class with Read & Write permissions to the problem folder. I then opened the folder, and it was empty. A short time later, the autosaved copy of my TextEdit document appeared in the folder, along with a TextEdit plist file. And I haven't seen another error message.
Yep, I can report the same fix worked for me. Interestingly, my icon for the folder had a little red circle with a dash on it (see attached image). That went away after I added my user name to the permissions. (Repairing permissions had not worked for me either.)

Thanks for the info. I don't use Textedit that much, but this was annoying me when I do.

Laird
 

Attachments

scottwhs

macrumors newbie
Mar 10, 2012
1
0
Working Around TextEdit Permissions

Using the procedure below I worked around the TextEdit save issue.

(Note:my original files are located in Documents/MyFirstFolder.)

1. In the Documents folder, create a new folder MySecondFolder.
2. Copy all files from MyFirstFolder into MySecondFolder.

3. Using TextEdit, open your file from MySecondFolder.
5. Add text, save the file. Delete text, save the file.
5. Repeat this a few times.

Notice the "document could not be saved" dialog does not appear.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.