TextEdit help needed!

Discussion in 'Mac Basics and Help' started by zobothehobo, Jul 27, 2014.

  1. zobothehobo macrumors newbie

    Joined:
    Jul 27, 2014
    #1
    Someone needs to help me, because I'm going insane. I'm trying to help my grandfather out, we're running Mac OS X 10.6.8 and I'm trying to get TextEdit to NOT save as a different document when he exits and saves. Currently, his primary method of saving is to click the x to exit the document, the program will ask him if he wants to save his changes, and when he clicks yes, it saves as a different document. Initially, I thought this was a simple preference issue and I could just change the default save settings to "save" rather than "save as" as it is on MOST word processors. But no.... It's apparently far more difficult than that and I cannot find ANYTHING about it when I google. Apparently a later version of the Mac OS changed things so now save as is gone or something and that's all I can fine when I google... But this is the opposite problem that I have. I'll try to re-train him to manually click "save" instead of exiting and clicking save when it asks him, but he's old and I don't think that's going to work very well. He's becoming quite distressed by the fact that for every document he has, there's 20 different versions- ALL SAVED UNDER THE EXACT SAME NAME! How macs an save multiple documents under the EXCT SAME NAME, I will never know. This is why I'm a windows person, to be honest... At any rate... does anyone know what I am talking about and is there a way to change this?????????????
     
  2. Bruno09 macrumors 68020

    Joined:
    Aug 24, 2013
    Location:
    Far from here
    #2
    Hi,

    go to TextEdit / Preferences.

    Set the "Open and Save" tab up like this : check the "Delete the automatic backup file" box

    [​IMG]
     
  3. Jessica Lares macrumors G3

    Jessica Lares

    Joined:
    Oct 31, 2009
    Location:
    Near Dallas, Texas, USA
    #3
  4. Bruno09 macrumors 68020

    Joined:
    Aug 24, 2013
    Location:
    Far from here
  5. zobothehobo thread starter macrumors newbie

    Joined:
    Jul 27, 2014
    #5
    That's what I thought that setting was... but it IS checked and it has been. It was when I went into preferences, I unchecked it, saved, and rechecked it to reset the setting and it's still not working
     
  6. Bruno09 macrumors 68020

    Joined:
    Aug 24, 2013
    Location:
    Far from here
    #6
    I have checked again on 10.6.8 and I do not have this issue.

    You might need to delete a TextEdit preference file.

    Do you know how to do this ?

    Did you try to restore the preferences to default ?
     
  7. Jessica Lares macrumors G3

    Jessica Lares

    Joined:
    Oct 31, 2009
    Location:
    Near Dallas, Texas, USA
    #7
    Ah, right. I read that wrong, I'm sorry. :eek:

    There is a program called ForeverSave that you might have a look at. The easiest thing would be to tell him to push Command-S before exiting, but I understand.
     
  8. ApfelKuchen macrumors 68030

    Joined:
    Aug 28, 2012
    Location:
    Between the coasts
    #8
    What happens if you close TextEdit while a document is open? Does it prompt to Save, or does it simply close?

    The behavior you describe sounds more like Lion/Mountain Lion/Mavericks, which continuously auto-save. Are you sure you're on Snow Leopard?

    I less-than-fondly remember the days when you'd hit CMND + S (or CTRL + S on PCs) every few minutes or risk losing all. At least under today's OS X, I've lost that fear - the system can crash and I get everything back, or perhaps everything but the last few characters.

    System Preferences > General: Ask to keep changes when closing documents

    That preference, if available to you, will end that "save-when-you-close" scenario that's driving you nuts.

    The only question then is, can you trust auto-save to have saved the current document's condition when you close it?

    I suggest experimenting. It should only take a few minutes. Turn off that preference. Open a test document, make some changes, close it. Open it again.
     

Share This Page