TextEdit keeps interfering with Google search

Discussion in 'Mac Basics and Help' started by Death-T, Jul 17, 2012.

  1. Death-T, Jul 17, 2012
    Last edited: Jul 18, 2012

    Death-T macrumors regular

    Death-T

    Joined:
    May 18, 2012
    Location:
    Savannah, Georgia
    #1
    Whenever entering a Google search with Firefox on Mountain Lion, the browser keeps prompting me to open or save something with TextEdit. Sometimes I will have no problems with this, while other times I will have to exit this window out after every letter I type. Here's an attachment of what I'm talking about.

    So basically, yeah how do I fix that? It's getting pretty annoying.
     

    Attached Files:

  2. r0k macrumors 68040

    r0k

    Joined:
    Mar 3, 2008
    Location:
    Detroit
    #2
    Firefox? That's part of the problem. I've never been impressed with the quality of FF running on OSX. Safari and Chrome run quite well but FF is prone to all sorts of errors (in my experience). This seems to be a "file association" problem. Have you tried setting your default browser to Chrome or Safari, then see if you get prompted to open links in those browsers while you are typing a search in FF.

    If this is the case, your problem would be solved by using a different browser. If you are being prompted to open textedit even in Safari or Chrome, you will have to dig a little deeper to solve the association that has OSX thinking you want to edit rather than display html (that's what OSX usually thinks textedit can do with html... edit it).
     
  3. samh macrumors 6502

    Joined:
    Oct 29, 2009
    #3
    More likely than an OSX file association problem, it's probably a Firefox/MIME-type issue. In Firefox Preferences > Applications you might want to see if anything is set to open with TextEdit. For some reason, Firefox think you want to be opening what I'm guessing is the return from Google's servers for autocomplete (which of course would come down as a file).
     

Share This Page