TF2 didn't run with Boot Camp

Discussion in 'Mac and PC Games' started by madcap, Aug 29, 2009.

  1. madcap macrumors newbie

    Aug 28, 2009
    So I got my new Macbook pro just a little while ago, today i was hoping to get everything set up so i could at least play Team Fortress 2 on it. After I set up boot camp and installed windows 7 on it everything seemed to be running smoothly. Later today, TF2 had just finished downloading but when i tried to play the game couldn't even load the main start up page. It just immediately crashes right after start up. I tried updating windows and when I went to try to update the drivers there was a problem during installation.

    I'm not exactly sure what i did wrong. I followed the boot camp instructions. I'm using NVIDIA GeForce 9600M GT with 256MB. Is there some obvious step that i'm missing?
  2. BradenG macrumors regular

    Jul 13, 2009
    I'm a TF2 freak, but it's hard for me to say. The only reason I have a Bootcamp partition is to play TF2 and WinXP is a great OS for TF2 (all Source engine games) so I just used XP w/SP3 - I'm not familiar with Win7, so there could be a complication in that regard somewhere. :confused:
  3. customsnow macrumors newbie

    Sep 1, 2009
    did you install the boot camp drivers in windows by sticking in your snow leopard/leopard/your macbook disk you need those drivers as well as the nvidia driver
  4. Slipster macrumors newbie

    Nov 10, 2009
    I did exactly the same, installed Windows 7 on my mac book pro, problem i had is that the disc didnt install all the drivers, Some missing i find is the inbuilt Mic, and Graphics driver.

    After i installed the graphics driver tf2 runs smoothly, before that it got to the Steam Terms and conditions and crashed.
  5. Dagless macrumors Core


    Jan 18, 2005
    Fighting to stay in the EU
    Awesome, same here!
    OP - does the resolution change before the crash? This is one of the first things the game does so it would help explain if it was caused by a bad installation or something in the launch code.
    Have you tried any other games? If you have the time grab a demo of a Source engine game.

    One thing you could try is right clicking on the game in Steam, properties, set launch options select and add "-dxlevel 80". This disables DX9, it'd just help diagnose the problem a bit better. If you want add a space and add "-novid" to turn off the Valve intro video.
  6. Tbone999 macrumors member

    Jun 18, 2009
    Been playing TF2 with Crossover Games for about 7 months now

    It runs very well. You can try it out before buying it. I play a whole lot of TF2 (as well as Left4Dead) and I think it's a pretty easy way to get these games up and running on your mac.
  7. adamjohn_98 macrumors member

    Sep 7, 2005
    What are the specs on your Mac? I'm hoping to do this same thing on my new i7 iMac when it comes in.

Share This Page