The App Store app thinks Xcode is installed, but I deleted Xcode.

Discussion in 'Mac Apps and Mac App Store' started by moonman239, May 5, 2014.

  1. moonman239 macrumors 68000

    Joined:
    Mar 27, 2009
    #1
    I deleted Xcode and now want to reinstall it, but the App Store app says Xcode was installed. There was only one copy on my machine, and the only connected external hard drive only has Time Machine backups.

    Edit: I tried holding down the Option key while in the Purchases pane, and I did not see an "Install" button next to Xcode.
     
  2. ChristianJapan macrumors 601

    ChristianJapan

    Joined:
    May 10, 2010
    Location:
    日本
    #2
    Try pressing "option" key and mouse click (not sure if "option" was the right one though; try the others too)
     
  3. moonman239 thread starter macrumors 68000

    Joined:
    Mar 27, 2009
    #3
    I tried that, it didn't do anything.

    Anyway, I found out that pressing the X button next to the app in Launchpad while the icons are shaking doesn't delete the app itself. The app will still be in the Applications folder.

    Apple wants to make Mac OS X more like iOS. I wonder if that means altering the behavior of the aforementioned X button.
     

Share This Page