The application PubSubAgent quit unexpectedly.

Discussion in 'macOS' started by MacBoy1981, Nov 17, 2007.

  1. MacBoy1981 macrumors newbie

    Joined:
    Nov 15, 2007
    #1
    Since downloading 10.5.1, I have had the message below pop up about every half hour. Almost every time, I click "Report...." to send to failure to Apple. I have also tried clicking "Relaunch," but that done nothing to fix the problem. Half an hour later, the popup comes back again. It has happened now more times than I can count. I have tried to research what this application is, but to no avail. Does anyone have any idea what I can do to fix this or to at least get rid of the pop up?


    Thanks for your help.
     

    Attached Files:

  2. NAG macrumors 68030

    NAG

    Joined:
    Aug 6, 2003
    Location:
    /usr/local/apps/nag
    #2
    It handles dotmac syncing. Apparently it is related to bookmark syncing. I would suggest turning bookmark syncing off until Apple gets a fix for it (apparently they're deleting threads about it so finding a fix is being difficult).
     
  3. MacBoy1981 thread starter macrumors newbie

    Joined:
    Nov 15, 2007
    #3

    I do not use dotmac, nor have I 'purposefully' turned on any bookmark syncing. How can I go about turning bookmark syncing off? I have looked at the dotmac preference pane and it it empty. It asks me if I would like to create an account or to enter existing information.
     
  4. NAG macrumors 68030

    NAG

    Joined:
    Aug 6, 2003
    Location:
    /usr/local/apps/nag
    #4
    Well that is weird. Have you ever had a dotmac account on that computer?
     
  5. jamesarm97 macrumors 65816

    Joined:
    Sep 29, 2006
    #5
    I have had this problem since day 1 of installing leopard on my wife's mini. I don't have the problem on my macbook pro or any of the other logins on her computer.
     
  6. NAG macrumors 68030

    NAG

    Joined:
    Aug 6, 2003
    Location:
    /usr/local/apps/nag
    #6
    Hm, and no dotmac ever on there I assume.

    I suggest tracking down the dotmac plists and whatnot, putting them in the trash, and relogging.
     
  7. MacBoy1981 thread starter macrumors newbie

    Joined:
    Nov 15, 2007
    #7
    1) Would you happen to know where/how I can find those?
    2) Is it possible to delete PubSub or dotmac entirely?


    I've narrowed the problem down to not being associated with my user login by using a test admin account, which produced the same error message every half hour. I then tried to find the plist in /Library/Preferences, but did not see anything resembling dotmac plists. Any help would be appreciated. Thanks again!
     
  8. MacBoy1981 thread starter macrumors newbie

    Joined:
    Nov 15, 2007
    #8
    Solution to Pubsub Agent problems . . .

    Solution:

    Manually download and reinstall the 10.5.1 update, found here:
    http://www.apple.com/downloads/macosx/apple/macosx_updates/macosx1051update.html

    This will re-patch the "updated" problematic files and fix the problem.


    I have had this problem since originally updating to 10.5.1. I just found this hint on another forum and it WORKED!!! The error msg no longer pops up!!! Pass it along . . .
     
  9. edmontonpaul macrumors newbie

    Joined:
    Jan 2, 2008
    #9
    PubSubAgent problems

    I've had the same problem since upgrading to Leopard. I just installed the 10.5.1 combo update as has been suggested here and in other forums. 5 minutes after I rebooted I got the PubSubAgent dialog box once again. It annoys me that another way to fix this is to turn off bookmark syncing with DotMac. Why do I pay for this service then? Come on Apple, why is this taking so long to fix?
     
  10. riscy macrumors 6502a

    riscy

    Joined:
    Jan 4, 2008
    Location:
    China
    #10
    I d'lded the manual update, ran it, and still have the same problem!

    We need Apple to release a fix for this, as well as the other "issues" connected with Leopard.

    The Xmas holidays are over - get to work, people!!!
     
  11. harcosparky macrumors 68020

    Joined:
    Jan 14, 2008
    #11
    I have this problem.

    Bookmark Syncing is NOT turned on.

    I went into /user/library/ and MOVED the PubSub folder from there to the Desktop and the nasty messages stopped.


    I do have a .Mac account and have had this computer on 10.5.1 since I bought it. The error messages just started popping up yesterday!
     
  12. LloydInFL macrumors newbie

    Joined:
    Feb 11, 2008
    #12
    Another thing to try

    If you have RSS feeds set up in Mail, delete them and use Firefox as your RSS reader.
     
  13. LAB macrumors newbie

    Joined:
    Dec 28, 2008
    #13
    Hey

    I cloned the hard drive of my MacBookPro for a hard drive upgrade.

    As far as I know all went OK but I am now getting this really annoying PubSubAgent quit unexpectedly error message. It is popping up very frequently.

    I noticed that people were having this problem in Jan 08 so I'm hoping someone may have an answer to my plea!

    Thanks for any help or advice anyone can give.
     
  14. kbodick macrumors newbie

    Joined:
    Dec 28, 2008
    #14
    PubSubAgent unexpectedly quits

    This has never happened to me until Christmas Eve and now it's happening all the time on both of my Macs!

    I've re-installed both OS 10.5.6 and Safari 3.2.1 and fixed disk permissions to no avail. I read that MobileMe updated some of their services last week but don't know if there is any coincidence or not.
     
  15. LAB macrumors newbie

    Joined:
    Dec 28, 2008
    #15
    Can anyone give any advice on this issue?

    Thanks
     
  16. n7eoj macrumors newbie

    Joined:
    Feb 15, 2009
    #16
    Same problem

    • I can't justify the expense of a MobileMe subscription
    • I do not have dotMac syncing enabled.
    • I am not subscribed to any RSS feeds.
    Configuration:
    24" 3.06GHz iMac, running OSX 10.5.6 that just installed the latest security update.
    Safari 3.2.1
     
  17. westcoast001 macrumors newbie

    Joined:
    Mar 13, 2009
    #17
    Hi,
    I just downloaded the latest updates for my Mac & now I'm getting the same error message. Puter is running really slow, & can't get mail to load or Safari to do anything except have that little colored circle going on like its trying to do something.
    Itunes, no probs, loads & can use normally.

    Took about 15 mins for my puter to finally activate when I turned it on. Its hopeless & terribly frutrating.
    Was working fine about 2 hours ago. Last thing I did was the update ( they come at you automatically & you just update ) turned puter off, had some dinner & turned it on.......all hell has broken loose.

    HELP??!! :confused:
     
  18. rinnin macrumors newbie

    Joined:
    Jul 25, 2002
    #18
    Same problem here after doing a software update.

    Was all fine till I updated to 10.5.6 and Safari 3.2.1.
    Very annoying :mad:
     
  19. angelwatt Moderator emeritus

    angelwatt

    Joined:
    Aug 16, 2005
    Location:
    USA
    #19
    Can you check the Console to see if there's some messages that we may be able to use to diagnose the problem further? You can also check for crash logs at ~/Library/Logs/CrashReporter. Also, have you tried the listed solution here of downloading the update manually and installing from that?
     

Share This Page