The autocorrection of 'K'

Discussion in 'iOS 8' started by Patrick G, Oct 20, 2014.

  1. Patrick G macrumors regular

    Joined:
    Sep 12, 2014
    #1
    One of the biggest annoyances of iOS 8 for me is the fact that if I respond to a text with 'K', it gets autocorrected to 'I'. Anyone else? The OS should be smart enough to know not to do that in the context of a text message, given that it's probably the most-commonly texted "word" on the planet.
     
  2. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #2
    I have never sent that letter as a word nor have I ever received it as a word in that fashion.
     
  3. Alrescha macrumors 68020

    Joined:
    Jan 1, 2008
    #3
    You can either 1) Turn off autocorrect, or 2) Teach it to not correct your usage of "k". Choose.

    A.
     
  4. bkends35 macrumors 6502a

    bkends35

    Joined:
    Feb 24, 2013
    Location:
    USA
    #4
    Add "K" to your dictionary and it won't autocorrect it. FWIW, "K" has become a rude way to say "okay", I know a few years ago everyone would say "K" instead but most people will think you're mad if you're saying just "K". Not that it's relevant here, just saying. ;)
     
  5. Patrick G thread starter macrumors regular

    Joined:
    Sep 12, 2014
    #5
    Thanks for the suggestions. I use it all the time with family, who are the people with whom I most often exchange texts.
     
  6. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #6
    Perhaps adding a keyboard shortcut to change 'k' or 'K' on its own to just be 'K' or even "OK" (if not "Okay").
     
  7. iolinux333 macrumors 68000

    Joined:
    Feb 9, 2014
    #7
    Lots of folks have been using Kk a lot lately. Even saying it. I like Kk!

    Kk?
     
  8. Patrick G thread starter macrumors regular

    Joined:
    Sep 12, 2014
    #8
    Turns out you can't do this, and I'm pretty sure I tried this in the past, which is why I remain frustrated. Shortcuts must be minimum two characters in length. :mad:
     
  9. edogyip macrumors member

    Joined:
    May 26, 2009
    #9
    k.
     
  10. Patrick G thread starter macrumors regular

    Joined:
    Sep 12, 2014
    #10
    I went with 'kk' since 'k.' requires three button presses.
     
  11. Mr Hands macrumors regular

    Joined:
    Oct 11, 2014
    #11
    Ok.
     
  12. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #12
    I guess you can then perhaps set it up to make it so that "kk" becomes just 'K' or even "OK" so it's just one extra press of the same key which is still rather quick and pretty much gets the job done.

    ----------

    Sounds like you might have actually done that.
     
  13. MVallee macrumors 6502a

    MVallee

    Joined:
    Feb 8, 2007
    Location:
    Ontario, Canada
    #13
    Happens to me all the time too! I end up typing "k" and it sends "I" and then I try again and end up sending another "I" and then I'll get frustrated and have to type "k*". Almost makes me want to start texting in proper English...almost ;)
     
  14. edogyip macrumors member

    Joined:
    May 26, 2009
  15. Patrick G thread starter macrumors regular

    Joined:
    Sep 12, 2014
    #15
    I can't believe it took this long for someone to ask me that question. :D
     
  16. appleii.c macrumors 6502

    appleii.c

    Joined:
    Mar 18, 2013
    #16
    I think the OS is smart enough to know that "K" is not a word.
     
  17. The Doctor11 macrumors 603

    The Doctor11

    Joined:
    Dec 15, 2013
    Location:
    New York
    #17
    My extensive testing shows this
     

    Attached Files:

  18. Armen macrumors 604

    Armen

    Joined:
    Apr 30, 2013
    Location:
    127.0.0.1
    #18
    Settings > General > Keyboards > Shortcut

    create a new shortcut

    Phrase: "Ok"
    shortcut: "K"

    problem solved. Every time you type K it will auto-correct to Ok.
     
  19. Patrick G thread starter macrumors regular

    Joined:
    Sep 12, 2014
    #19
    Oh, but it is in the SMS world:

    Webopedia

    Wikipedia

    ----------

    Those steps are not possible within iOS. Try it yourself.
     
  20. newtestleper macrumors 6502

    Joined:
    Jun 17, 2013
    #20
    To save anyone trying it, the phrase has to be at least two letters. Why not tell people this instead of being passive-aggressive?
     
  21. Armen macrumors 604

    Armen

    Joined:
    Apr 30, 2013
    Location:
    127.0.0.1
    #21
    do kk for the shortcut.
     
  22. Patrick G thread starter macrumors regular

    Joined:
    Sep 12, 2014
    #22
    Because I already did earlier in the thread.
     
  23. iolinux333 macrumors 68000

    Joined:
    Feb 9, 2014
    #23
    Kk.
     

Share This Page