THE clean install topic for ML

Discussion in 'OS X Mountain Lion (10.8)' started by nampramos, Jul 25, 2012.

  1. nampramos macrumors 6502

    Joined:
    Dec 14, 2010
    Location:
    Portugal
    #1
    I have read quite a few topics addressing this problem lately and I have this problem as well.

    I have a late 2008 MacBook (5,1) and I cannot manage to make a clean install with ML. In fact, I cannot make a clean install with Snow Leopard or Lion. It only allows me to make a clean install with Leopard (that was the OSX version my MacBook came originally with when I bought it).


    Can someone finally clarify this issue for me and for all the others that seam to be having the same issue? Please?

    Don't come here saying I'm doing something wrong with my bootable USB stick. For sure I'm doing something wrong, you don't need to tell me that. I rather read from you what I'm doing wrong and how to fix it in order to make a clean install with Mountain Lion.


    Thank you!
     
  2. yojitani macrumors 68000

    yojitani

    Joined:
    Apr 28, 2005
    Location:
    An octopus's garden
    #2
    If your current drive is backed up on a separate drive, I'd recommend wiping the internal HD with the bootable USB stick. You can do this by starting up your computer with the USB stick plugged in and holding down the option key. Then select the drive with ML on it. From the install screen, go to disk utility and then erase your internal HD (Mac HD or whatever you call it). You will have to rename the drive (you can use the same name), but make sure that you select GUID Partition table for the reformatted and renamed drive (partition).

    Then leave Disk Utility and install ML on the freshly wiped HD!

    or are you asking what's wrong with your installer on your USB stick? If you are having trouble with that, I'd imagine the problem is that you didn't format the stick using the GUID Partition Table. That is often the problem... That, or the person is not using the correct source file. Remember, it has to be the ESD.dmg file (or whatever it's called now!), you can't use the entire installer that you download from Apple!
     
  3. nampramos thread starter macrumors 6502

    Joined:
    Dec 14, 2010
    Location:
    Portugal
    #3
    Thanks for the answer!

    Unfortunately, I have done all that.

    I created a bootable USB stick which I previously formatted in the correct format and used GUID partition.

    I started my MacBook with the bootable USB stick by holding down the option key and then formatted the HDD through the bootable USB stick and after that proceeded with the install. Once I try to install, I get a message saying I cannot install OS X on this computer.

    Confusing? Frustrating?
     
  4. yojitani macrumors 68000

    yojitani

    Joined:
    Apr 28, 2005
    Location:
    An octopus's garden
    #4
    Is your HD partitioned? Are you sure that your HD is properly formatted to receive the ML install? Not only GUID, but also Mac OS Extended (journaled). If you go into Disk Utility and click on the install partition and then click command and "i" can you paste the non-sensitive information here?
     
  5. nampramos thread starter macrumors 6502

    Joined:
    Dec 14, 2010
    Location:
    Portugal
    #5

    The receiving HDD has been formatted using GUID and Mac OS Extended (Journaled). Same goes for the bootable USB disk.

    The receiving HDD has a single partition while the bootable USB disk has two partition. One for the installation and other with a backup.


    What I can't understand is why Leopard installs under this situation while Snow Leopard, Lion and Mountain Lion don't.
     
  6. Macman45 macrumors demi-god

    Macman45

    Joined:
    Jul 29, 2011
    Location:
    Somewhere Back In The Long Ago
  7. nampramos thread starter macrumors 6502

    Joined:
    Dec 14, 2010
    Location:
    Portugal
    #7
    Mine is a late 2008 MacBook 5,1 which is aluminum. It is part of that list.

    Don't forget the part where I say that neither Snow Leopard or Lion let me perform a clean install. It isn't just Mountain Lion.


    If I want to do a clean install, I had to go all the way back to Leopard.


    There has to be something wrong for sure because I must be able to perform a clean install with SL, Lion or ML. What is wrong, I just don't know...
     
  8. VTECaddict macrumors 6502

    Joined:
    Sep 15, 2008
    #8
    I clean installed SL and Lion perfectly fine on my late 2008 MBP. I just upgraded to ML though instead of clean install this time around.
     
  9. nampramos thread starter macrumors 6502

    Joined:
    Dec 14, 2010
    Location:
    Portugal
    #9
    Yeah I'm sure it is possible to do a clean install with any of the versions higher than Leopard on my MacBook. I just can't figure out what the problem might be with mine...
     
  10. Michaelgtrusa macrumors 604

    Michaelgtrusa

    Joined:
    Oct 13, 2008
    Location:
    Everywhere And Nowhere
    #10
    I will download ML again and clean install soon.
     
  11. nampramos thread starter macrumors 6502

    Joined:
    Dec 14, 2010
    Location:
    Portugal
    #11
    Will you use a bootable USB HDD to perform the clean install?

    Let me know exactly how you do it. It will probably be like I'm doing it though...


    No one else has any clues of what might be wrong on my MacBook? Some EFI problem? Firmware? Anything?


    Thanks!
     
  12. Steve121178 macrumors 68040

    Steve121178

    Joined:
    Apr 13, 2010
    Location:
    Bedfordshire, UK
    #12
    http://blog.gete.net/lion-diskmaker-us/

    Download Lion DiskMaker 2.0rc2 ( ZIP file, about 4 MB).

    Download ML

    Run DiskMaker 2.0rc2 & follow instructions



    I used this method last night and it couldn't have been easier.
     
  13. nampramos thread starter macrumors 6502

    Joined:
    Dec 14, 2010
    Location:
    Portugal
    #13

    Great tip! I will try it out later once I get home. Thanks!
     
  14. nampramos thread starter macrumors 6502

    Joined:
    Dec 14, 2010
    Location:
    Portugal
    #14
    This is really starting to annoy me now!

    I used that Lion Disk Maker to create a bootable USB stick with it.

    When I start up my MacBook with it the installation goes straight to that window with the big X and the progress bar under.

    I'm not given any option before. It tries to immediately perform the install and seconds later I get an error message saying Mac OS X cannot be installed on this computer.


    I need expert help, for what it seems. Any expert around here? Help would be much appreciated. Thank you!
     
  15. yojitani, Jul 26, 2012
    Last edited: Jul 26, 2012

    yojitani macrumors 68000

    yojitani

    Joined:
    Apr 28, 2005
    Location:
    An octopus's garden
    #15
    Could you post a link to the site you are using to set up the install drive? I've been able to do this on the same machine for all three OSs that you say you haven't. SL was a little different from Lion and ML, however. It sounds like it's not the thumb drive but something with your computer. What version of Disk Utility are you using to wipe the drive? If you are using Lion or even SL, could you enable debugging in Disk Utility, turn on "Show every Partition" from the Debug menu, and take (and post) a screenshot of the drive you are trying to install to?

    The other possibility is that you have a bad piece of hardware. Have you checked your RAM? Also, is the pen drive fairly consistent? Have you tried booting the install drive from a different slot (the USB ports are not equal on these machines).

    Nobody can help you unless you give more of an insight into the state of your drive and the process you're using to set everything up.

    Edit: I read through your other thread on this topic. It sounds like your computer has a hardware issue. I had a similar problem with a first gen macbook pro. I never worked that one out. I had to install each new OS from a different computer with the MBP in target disk mode. If you have Apple Care, take the computer in and explain the issues you've been having. That said, I now wonder whether your copy came from MAS...
     
  16. nampramos thread starter macrumors 6502

    Joined:
    Dec 14, 2010
    Location:
    Portugal
    #16

    I am using a MacBook Air from late 2010 which is running Lion to create the bootable USB stick.

    I have tried with two different USB drives. One is a thumb drive with 8GB from LaCie and the other one is an external HDD 2,5'' with 160GB (it was actually the old HDD I had on my MacBook.

    My MacBook has upgraded HDD which I upgraded to a WD 500GB (as seen in my signature) and I also upgraded the RAM to 2 * 4GB from Crucial.

    Leopard install fine from the original DVD and then I had before Snow Leopard updated over Leopard and consequently I updated SL to Lion.

    Now that I wanted to do a clean install of ML, I get these problems.

    If I click to check the thumb drive where I have the bootable image of ML I get this:

    Verifying volume “OS X Mountain Lion Install Disk - 10.8”
    Checking file systemChecking Journaled HFS Plus volume.
    Checking extents overflow file.
    Checking catalog file.
    Checking multi-linked files.
    Checking catalog hierarchy.
    Checking extended attributes file.
    Checking volume bitmap.
    Checking volume information.
    The volume OS X Mountain Lion Install Disk - 10.8 appears to be OK.


    I cannot find that debug mode on Disk Utility. The version is 12.1.1

    What other info can I provide? Shall I post some photos from my MacBook booting? There's not much to show...

    I start up the MacBook with the option key pressed down, then I selected USB bootable image which immediately brings the Apple logo to the front and it starts loading up. Once it finishes loading up the install moves straight away to the big X window with the progress bar under and just after 2 or 3 seconds I get the message saying there was a problem with installing Mac OS X on this computer. And that's it.

    When I go to disk utility on the MacBook (after the installation failed) I see my HDD which is correctly formatted, I see the SuperDrive, the USB thumb drive with one partition of the bootable image of ML and I see a "disk2" which under it has "Mac OS X Base System".

    That's it...
     
  17. nampramos thread starter macrumors 6502

    Joined:
    Dec 14, 2010
    Location:
    Portugal
    #17
    No one else is able to help me out? Should I just forget a clean install of ML on my MacBook? (or actually a clean install of everything after Leopard)
     
  18. SnowLeopard2008 macrumors 604

    SnowLeopard2008

    Joined:
    Jul 4, 2008
    Location:
    Silicon Valley
    #18
    Last resort is bringing it into an Apple Store and ask them to help you clean install ML. Maybe try re-downloading the ML installer?
     
  19. mactmaster macrumors 6502

    Joined:
    Jun 16, 2010
    #19
    The USB thumb drive you created could have not worked right... using Lion Disk Maker I had to modify the AppleScript it uses because it would not detect my external 300GB drive as a removable disk.

    I would try to first use Disk Utility that you get after installation failure to repartition the drive and make sure the GUID option is selected. Try running installation again after that and if it fails I would look at making a new install disk using another Mac.

    Hope you can get it working.
     
  20. nampramos thread starter macrumors 6502

    Joined:
    Dec 14, 2010
    Location:
    Portugal
    #20
    I am based in Sweden, no Apple Stores here...

    I downloaded twice already from the app store and made more than one bootable USB drive to install it from.

    Now I was trying to update directly from Leopard to ML. Is that possible? How can I do it?

    When I try to do it the install quits immediately:

    "The application Install OS X Mountain Lion quit unexpectedly."


    If I click in Report I get the following in Problem Details:

    Process: Install OS X Mountain Lion [129]
    Path: /Volumes/OS X Mountain Lion Install Disk - 10.8/Install OS X Mountain Lion.app/Contents/MacOS/Install OS X Mountain Lion
    Identifier: Install OS X Mountain Lion
    Version: ??? (???)
    Code Type: X86-64 (Native)
    Parent Process: launchd [87]

    Date/Time: 2012-07-27 18:45:00.951 +0100
    OS Version: Mac OS X 10.8 (9F2088)
    Report Version: 6

    Exception Type: EXC_BREAKPOINT (SIGTRAP)
    Exception Codes: 0x0000000000000002, 0x0000000000000000
    Crashed Thread: 0

    Dyld Error Message:
    unknown required load command 0x80000022


    And the following in System Configuration:

    Model: MacBook5,1, BootROM MB51.007D.B03, 2 processors, Intel Core 2 Duo, 2 GHz, 8 GB
    Graphics: kHW_NVidiaGeForce9400MItem, NVIDIA GeForce 9400M, sppci_pci_device, 256 MB
    Memory Module: BANK 0/DIMM0, 4 GB, DDR3, 1067 MHz
    Memory Module: BANK 0/DIMM1, 4 GB, DDR3, 1067 MHz
    AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x8D), Broadcom BCM43xx 1.0 (4.170.83.15)
    Bluetooth: Version 2.1.1f10, 2 service, 1 devices, 1 incoming serial ports
    Network Service: AirPort, AirPort, en1
    Serial ATA Device: WDC WD5000BUDT-63G8FY0, 465.76 GB
    Serial ATA Device: HL-DT-ST DVDRW GS21N
    USB Device: Built-in iSight, (null) mA
    USB Device: XtremKey, (null) mA
    USB Device: Apple Internal Keyboard / Trackpad, (null) mA
    USB Device: IR Receiver, (null) mA
    USB Device: BRCM2046 Hub, (null) mA
    USB Device: Bluetooth USB Host Controller, (null) mA

    ----------

    And I forgot to mention that the installer starts up in the MacBook Air which is running Lion (while in my MacBook it quits unexpectedly, although it is running Leopard at the moment).
     
  21. nampramos, Jul 27, 2012
    Last edited: Jul 27, 2012

    nampramos thread starter macrumors 6502

    Joined:
    Dec 14, 2010
    Location:
    Portugal
    #21
    My installation adventure keeps on going.

    Now I grabbed my Snow Leopard copy and made a bootable USB drive with it to install over Leopard.


    Surprise: I cannot install SL on my MacBook which is now running Leopard.


    So before I had Lion working fine which was updated from Snow Leopard which before was updated from Leopard.

    Now I erased my HDD, tried to perform a clean install of ML which did not work and had to clean install Leopard on it again. But now I can't have anything else than Leopard.


    Just great!


    [​IMG]
     

Share This Page