The disc you inserted was not readable by this computer

Discussion in 'MacBook' started by DukeSnyd, Sep 27, 2011.

  1. DukeSnyd, Sep 27, 2011
    Last edited by a moderator: Sep 27, 2011

    DukeSnyd macrumors member

    Joined:
    Nov 8, 2007
    #1
    I can't get my 2TB Western Digital external HDD to work.
    I have had this drive for about a year, and it has worked fine until this week.
    whenever i plug it into my computer I get a " the disk you inserted was not readable by this computer" error message. it then gives me the options to "ignore" or "eject". it shows up in disk utilities as "2 TB WD Ext HDD 1021 Media" but unlike my other external HDD, (500 GB WD 5000AAK), the devices name "Media" does not appear underneath the technical name

    both external HDDs have their own power source (they are the same connection, i've tried switching sources, get the same results " the disk you inserted was not readable by this computer")

    I tried to plug it into a Dell this morning (windows seven) and it would not recognize the drive (either drive, for that matter)

    I now have them both plugged into an 3.2ghz i3 iMac 10.6.8
    the 500gb drive is working fine, the 2TB is giving me the same " the disk you inserted was not readable by this computer" message.

    (my computer is a 2.0 c2d 4gb macbook from 2007ish running lion)

    i have attached a screen shot of the warning. all advise is a great help!

    here is the disk utility screen shot
     

    Attached Files:

  2. Detrius macrumors 68000

    Joined:
    Sep 10, 2008
    Location:
    Asheville, NC
    #2
    Disk Utility says that there's no partition table on the drive. If it was a GPT partition table, there may still be an extra copy at the end of the drive. If you click the "info" button in Disk Utility, it will give you the device ID of the drive (e.g. disk3).

    Try this in the terminal:

    sudo gpt recover /dev/disk<id you found>

    That will restore the backup copy of the partition table to the primary copy. Of course, it will only work if you have a GPT partition table.

    Tools like Data Rescue and Disk Warrior will only work if you have a functional partition table, but tools like R-Studio (on Windows) can scan the whole drive (even Mac drives) and give you a pretty darn good idea of where your various volumes are located (at that point, you can manually recreate the partition table).


    Of course, you may also have a bad hard drive.
     
  3. session101 macrumors regular

    Joined:
    Aug 25, 2011
    Location:
    Salt Lake City, UT
    #3
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_3_5 like Mac OS X; en-us) AppleWebKit/533.17.9 (KHTML, like Gecko) Version/5.0.2 Mobile/8L1 Safari/6533.18.5)

    You could copy the files over onto your pc and plug the drive into your Mac... Then reformat with the Mac, then plug back into your pc and transfer the files back over
     
  4. Detrius macrumors 68000

    Joined:
    Sep 10, 2008
    Location:
    Asheville, NC
    #4
    How is that oing to help? The PC doesn't recognize the volume either.
     
  5. session101 macrumors regular

    Joined:
    Aug 25, 2011
    Location:
    Salt Lake City, UT
    #5
    if both system's do not recognize your drive... then its EFFFFFED!:eek::eek:
     
  6. Detrius macrumors 68000

    Joined:
    Sep 10, 2008
    Location:
    Asheville, NC
    #6
    Not necessary. It just means recovery won't be obvious.
     
  7. TamaraE macrumors newbie

    Joined:
    Mar 28, 2012
    #7
    I have the EXACT same problem with my WD 2TB.

    Did you ever find out what the main problem was and how to fix it? I am just hoping that it doesn't require mechanical repair. This hard drive has some really important files on it.

    Please let me know what you've found.

    Thanks so much!!!
     
  8. Macman45 macrumors demi-god

    Macman45

    Joined:
    Jul 29, 2011
    Location:
    Somewhere Back In The Long Ago
    #8
    Somewhere in the forums I'm sure Ive read that WD stated that there are issues with the 2TB drive...Can't find the thread at the moment. But if it's not recognised by so many different systems I'd be inclined to think corruption, or failure.
     
  9. blamelewis macrumors newbie

    Joined:
    Jul 10, 2008
    Location:
    Scotland
    #9
    Thanks!

    Detrius - I just tried this on a Lacie Rugged drive that failed AND IT WORKED - thank so much!

    Best

    Tim

     
  10. danicroitor macrumors newbie

    Joined:
    Aug 4, 2012
    #10
    any ideas if your solution won't work?
    I have the same problem but sudo gpt recover doesn't work for me.
    Here is a print screen ( gpt recover: /dev/disk1: no primary or secondary GPT headers, can't recover )
     
  11. Detrius macrumors 68000

    Joined:
    Sep 10, 2008
    Location:
    Asheville, NC
    #11
    If you have an extra drive somewhere that can hold more than 2GB, I would create an image of the drive and muck around with the image. A tool like gddrescue is excellent for creating an image of a physical disk, especially if it has bad blocks (this is available via MacPorts as the package ddrescue). Once you have the disk image, you can do your work on a shadow copy of the image so that you don't have to worry about risk of damaging the disk image such that you have to reimage the drive. ( http://krypted.com/mac-os-x/shadow-mounting-with-hdiutil/ ). I've been told that it's possible to attach a physical drive with a shadow file, but I've never tried it myself, so I don't know what all is involved. If you don't have space to make an image (most people won't have an extra 2GB of space sitting around somewhere), then this would be a good thing to look into.

    If you don't have access to high-end software that will scan a drive or image without a partition table (e.g. R-Studio, which is only available on Windows), then you could use an open source tool like testdisk to try to find your volumes. ( http://www.cgsecurity.org/wiki/Running_TestDisk -- also available via MacPorts as the package testdisk) This software may be able to tell you where your HFS+ volume is physically located on the disk, along with its size, if you're lucky.

    Once you have the location and size of the volume from either R-Studio or testdisk, you can use gpt at the command line to create a new partition table. At this point, if you know the location and size of the original HFS volume, it doesn't matter whether or not the original partition table was in GPT format (unless the partition table happened to be smaller than GPT, and that would be a problem).

    It's been a few months since I've done all of this, as I've moved on to being a programmer again instead of a bench technician, so I'm a little rusty on the precise details, but the important parts would go something like this (and check the man page for accuracy):

    gpt create /dev/disk<your id>
    gpt add -i 2 -b <start> -s <size> -t hfs /dev/disk<your id>

    At this point, the volume may automatically mount, but more likely, it won't. If it doesn't, run DiskWarrior and only DiskWarrior. Nothing else remotely comes close for repairing HFS+ directory structures. If you're running against a shadow copy, feel free to click replace. Otherwise, preview and manually copy any data out of the preview.


    I know I've left a lot out, but it's a really vague topic, since it basically boils down to generic data recovery from a drive with no obvious partition table. Getting the data at this point requires the right tools, which do exist, but they aren't user-friendly.
     
  12. Dreamermike macrumors newbie

    Joined:
    Jun 17, 2013
    #12
    I Tried: " sudo gpt recover /dev/disk2 "

    but it says:
    gpt recover: unable to open device '/dev/disk2': Resource busy


    what do i do?
     

Share This Page