The disk cannot be partitioned because some files cannot be moved?

Discussion in 'Windows, Linux & Others on the Mac' started by Haruhi, Dec 14, 2009.

  1. Haruhi macrumors regular

    Joined:
    Sep 19, 2008
    #1
    Back up the disk and use Disk Utility to fomat it as a single Mac OS Extended (Journaled) volume. Restore your information to the disk and try using Boot Camp Assistant again.

    I don't have anything to backup to, so what can I do? :eek:
     
  2. GoCubsGo macrumors Nehalem

    GoCubsGo

    Joined:
    Feb 19, 2005
    #2
    Nothing, you really need to backup ... that's just how it is.

    I am of the school of thought that you should always have a spare drive laying around for such events.
     
  3. Haruhi thread starter macrumors regular

    Joined:
    Sep 19, 2008
  4. Platonist macrumors member

    Platonist

    Joined:
    Nov 3, 2006
    #4
    I had this same thing happen to me recently. I deleted a few GBs of data (things that I clearly didn't need anymore) and things went fine afterward. It could be that there is insufficient free space available to move things around so that Bootcamp assistant can create the new partition without wiping the drive clean.
     
  5. Tachion macrumors member

    Joined:
    Jun 24, 2009
    #5
    This. I've had this happen, and it usually means there's not enough free space to rearrange large file chunks for partitioning. Either free up some space, or make the Boot Camp partition smaller.

    You do -not- need to reformat and restore your data. Well, maybe you do if there's some sort of disk error, but to do that now would be ridiculous and likely not even solve your problem.
     
  6. wiivault macrumors newbie

    Joined:
    Dec 11, 2009
    #6
    Use a tool like iDefrag to defragment the drive. Worked for me after trying everything else. Virtual machine files are a known culprit. Best of luck.
     
  7. lamina macrumors 68000

    lamina

    Joined:
    Mar 9, 2006
    Location:
    Niagara
    #7
    I *JUST* finished reinstalling Snow Leopard on my freshly-zeroed 500GB drive, and I get this error. I have 285GB free. How can this not be possible? I reformatted thinking I would fix this error.
     
  8. The Flashing Fi macrumors 6502a

    Joined:
    Sep 23, 2007
    #8
    It has nothing to really do about bootcamp not being able to move files. Boot camp doesn't move anything. All it basically tells the disk is "allocate this continuous space as a separate partition." The keyword being allocate.

    Basically, there is data in that area, possibly system files. Basically, you want to allocate more space than there is continuous free space. Instead of going ahead and partitioning the area anyway, which would result in losing that data, it's throwing up the error.

    Basically, you can try your hand at defragging the data. If you just installed SL, then I wouldn't be surprised if there were some system files in the space.
     
  9. Jisuo macrumors 6502

    Joined:
    Dec 4, 2008
    Location:
    Sweden
    #9
    So I downloaded Drive Genious 2 to defrag and then it says you can't defrag because the program is running from the same volume. :rolleyes: Jesus, how many macs are there with more than one volumes? Great thinking.
     
  10. old-wiz macrumors G3

    Joined:
    Mar 26, 2008
    Location:
    West Suburban Boston Ma
    #10
    IIRC, you can run Drive Genius 2 from it's disk. I used to have it on an iBook G4 and you just booted the drive genius 2 disk and could work on the Mac boot disk. You did get a legal copy of Drive Genius, right? Not an illegal torrent?
     
  11. Jisuo macrumors 6502

    Joined:
    Dec 4, 2008
    Location:
    Sweden
    #11
    It was the demo version.

    I didn't need it in the end, I just made the partition smaller and it worked.
     

Share This Page