The disk you inserted is not readable by this computer, No Initialize option

Discussion in 'Mac Accessories' started by Denny0296, Jun 5, 2013.

  1. Denny0296 macrumors newbie

    Joined:
    Jun 5, 2013
    #1
    I got this error yesterday on my WD Elements 500gb. I found fixes, but most cases they can Initialise. Tried disk warrior, it wont read my drive partition nor Disk utility. Any hopes to resurrect this drive?
     
  2. Volkan1984 macrumors member

    Joined:
    Feb 7, 2013
    #2
    Could you try to open the enclosure, take the HDD out and try and connect it to another SATA to USB connector or a HDD dock?
     
  3. Denny0296, Jun 5, 2013
    Last edited: Jun 5, 2013

    Denny0296 thread starter macrumors newbie

    Joined:
    Jun 5, 2013
    #3
    Alright, I'll try

    Edit: Picture here: http://sdrv.ms/13FlcLW

    There is no SATA port
     
  4. g4cube macrumors 6502a

    Joined:
    Apr 22, 2003
    #4
    You are the proud owner of one of those low cost drives that have the USB controller built right into the drive. No SATA or IDE connector at all.

    Try to find another Mac or PC to see if you can resurrect this drive with the USB connection.
     
  5. Volkan1984 macrumors member

    Joined:
    Feb 7, 2013
    #5
    As I see it, the HDD has an USB port directly attached to it? That USB port is accessible through a hole in the HDD's enclosure right?

    ----------

    Plus the "golden" connector looks like a sort of IDE connection. There are probably IDE to USB convertors out there (given that the data on the HDD is important enough for the effort, of course).
     
  6. Denny0296 thread starter macrumors newbie

    Joined:
    Jun 5, 2013
    #6
    What benefit does it have?

    Tried plugging it in a MBA and a Mac Pro, no luck.

    ----------

    It doesn't look like an IDE port. Trying to look for pros to fix this.
     
  7. Volkan1984 macrumors member

    Joined:
    Feb 7, 2013
  8. FreakinEurekan macrumors 68040

    FreakinEurekan

    Joined:
    Sep 8, 2011
    Location:
    Eureka Springs, Arkansas
    #8
    I'd call that one a lost cause. Looks like WD only gives a 1-year warranty on Elements drives, so if it's older than that I'd toss it and get a new one.

    Warranty can run a wide range so keep that in mind when you're looking for a replacement, just in the WD line you can get as little as one year or as much as five. My Passport Elite and some My Passport Studio drives give 5 years, some Studio drives get 3 years. Here's the chart:

    http://support.wdc.com/warranty/policy.asp
     
  9. Giuly macrumors 68040

    Giuly

  10. cocacolakid macrumors 65816

    cocacolakid

    Joined:
    Dec 18, 2010
    Location:
    Chicago
    #10
    Wow, I've never seen one of those before.

    ----------

    Walmart has some lower priced extended warranties available too when you buy any electronic from them. I've never checked to see if it's available for external drives, but keep that in mind (and for electronics you buy from them, you have 30 days after a purchase to buy the warranty, which can be done right online).

    ----------

    I think that's the USB port in the middle of that green adapter.
     
  11. Denny0296 thread starter macrumors newbie

    Joined:
    Jun 5, 2013
    #11
    It shows in Disk Utility if I hit Ignore. It doesn't show any partition though
     
  12. Giuly macrumors 68040

    Giuly

    #12
    You can format (aka initialize) it from Disk Utility, then: Just select the hard drive and go to the Erase tab, give it a name and click Erase.
     
  13. Denny0296 thread starter macrumors newbie

    Joined:
    Jun 5, 2013
    #13
    Cant do anything, all greyed out
     
  14. Denny0296 thread starter macrumors newbie

    Joined:
    Jun 5, 2013
    #14
    The HDD is dead. Asked about it to a pro and they said its a bad sector inside.
     
  15. brand macrumors 601

    brand

    Joined:
    Oct 3, 2006
    Location:
    127.0.0.1
    #15
    A pro?

    A bad sector does not mean it is a bad hard drive. Hard drives are designed to account for bad sectors and will avoid them with writing and reading data. Additionally a hard drive with a bad sector can still be formatted and the bad sector will be recorded so that it no longer get written to.

    Again I ask, a pro?

    I am surprised they didn't open it and try to remove the bad sector.
     
  16. Denny0296 thread starter macrumors newbie

    Joined:
    Jun 5, 2013
    #16
    Sorry its my bad, i shouldn't have said that. Direct quote from the email.

    " From your description, it is likely that your drive is experiencing a problem with bad sectors therefore causing its contents to be unreadable."

    They didnt get hands on with my Hard drive yet.
     
  17. nisulid macrumors newbie

    Joined:
    Jul 7, 2013
    #17
    USB drive

    Ok, i have similar problem with USB drive/ SDHD 32GB

    It all started when I tried to move some files to it. It is used in a car multimedia device, in a SD adapter. When I tried to move files, it gave an error with the file, and I hit "cancel". Then I tried to eject and it wouldn't. then I hit force eject. Repeated everything over again. The it stopped reading my card.
    It is not the reader since I other cards are readable. I also put the SDHD into an USB and plugged in the USB drive - nothing.
    It shows nothing.
    Disk utility, Disk Warrior, Data Rescue, Data Guru, they all show nothing.
    Is the SDHD card dead for good?
    Can I somehow format it? I don't need the files in it.
     

Share This Page