The Disk You Inserted Was Not Readable By This Computer

Discussion in 'Mac Basics and Help' started by Habitat, Mar 13, 2011.

  1. Habitat, Mar 13, 2011
    Last edited: Mar 13, 2011

    Habitat macrumors newbie

    Joined:
    May 27, 2009
    #1
    All of a sudden out of the blue I get these errors - from both of my memory cards yesterday.

    [​IMG]

    Uploaded with ImageShack.us

    My memory cards work fine in my Camera - Canon T2i.

    But they will not be recognized on my Mac or even my little Windows Netbook.

    [​IMG]

    Uploaded with ImageShack.us

    Diskwarrior won't recognize it. Data Rescue hangs and doesn't go anywhere. And the repair section in Disk Utility is grayed out. I formatted the card in my camera and it still shows same error message above. and setting up a new partition in Disk Utility doesnt work either - it says it cant "find the allocated space" (or something similar)

    I'm out of ideas and have an important shoot wednesday... What do I do? please..
     
  2. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
    #2
    Can you connect the camera via USB to the MBP, while the SDHC card is still inside the camera, and then use Image Capture or LightRoom or Aperture or iPhoto to transfer your images like that?
     
  3. Habitat thread starter macrumors newbie

    Joined:
    May 27, 2009
    #3
    Yeah I used Adobe Bridge/Lightroom to transfer in some images this morning. Still Long..But at least that worked. So what could be the major error thats causing both of my memory cards to be unreadable?
     
  4. sicn macrumors member

    Joined:
    Mar 12, 2010
    #4
    Same thing happens for me with all kinds of USB sticks and external drives. This started (I believe) after the 10.6.6 or maybe 10.6.7 update.
     

Share This Page