The disk you inserted was not readable by this computer.

Discussion in 'MacBook Pro' started by dnaimagery, Jul 20, 2012.

  1. dnaimagery, Jul 20, 2012
    Last edited by a moderator: Jul 20, 2012

    dnaimagery macrumors newbie

    Joined:
    Jul 20, 2012
    #1
    I have a Seagate Freeagent Goflex Desk External Drive 3TB and it was working fine a week ago, but when I go to plug it into my Macbook Pro 15in mid-2010 model I get the following message:

    "The disk you inserted was not readable by this computer."

    with the options to "initialize", "ignore", or "eject".

    I searched the forums & saw a few people had some answers, so I tried using disk utility & terminal to restore the GPT headers, but I got this message in terminal when I tried that.

    ------------------------------------------
    sudo gpt recover /dev/disk3s3

    gpt recover: /dev/disk3s3: no primary or secondary GPT headers, can't recover
    DNA-Imagery-MBP:~ DNA$
    ------------------------------------------

    Does anyone else have any suggestions on what I can do or what the next step will be? I have important files I need to access & I can't have my external harddrive down like this. Any help would be much appreciated.
     
  2. brand macrumors 601

    brand

    Joined:
    Oct 3, 2006
    Location:
    127.0.0.1
    #2
    You need to look into data recovery? Software or a service, its up to you.
     
  3. themumu macrumors 6502a

    themumu

    Joined:
    Feb 13, 2011
    Location:
    Sunnyvale
    #3
    One of the first things to do when suspecting a disk corruption is to try it a few times and to try it with a different computer. Not sure if you did that, but it could be worth a try.
     
  4. ZipZap macrumors 601

    Joined:
    Dec 14, 2007
    #4
    Ive had this happen and jiggering the connection resolved it in one case. Otherwise, I suspect that differences in controllers of moving the drives to new enclosures contribute to this issue.
     

Share This Page