The Firewire 400 port on my Powerbook G4 1.67 is dead

Discussion in 'PowerPC Macs' started by platinumtone, Feb 6, 2009.

  1. platinumtone macrumors newbie

    Joined:
    Feb 1, 2009
    #1
    The Firewire 400 port on my Powerbook G4 1.67 is dead. It seems to have power on it but will not see anything plugged into it. I also cannot see it in the system profiler.

    This happened (I believe) because of a particular piece of equipment that was plugged into it because a similar thing happened to my desktop G4 when the same equipment was plugged in!

    I have worked around the problem by purchasing a cardbus adapter but this is not ideal as it doesn't provide power to drives.

    I have tried all the usual recommendations of resetting the power management etc but wondered if anyone has any other suggestions to wake the port up or should I just accept it is dead forever?
     
  2. BlueRevolution macrumors 603

    BlueRevolution

    Joined:
    Jul 26, 2004
    Location:
    Montreal, QC
  3. MatLane macrumors 6502a

    MatLane

    Joined:
    Sep 30, 2008
    Location:
    England, United Kingdom
    #3
    Sounds like it is..

    What i would do is take it to an apple store and see what they recommend.

    Always worth the try

    All the best
    ML:apple:
     
  4. bjewett macrumors member

    Joined:
    Apr 28, 2005
    Location:
    Champaign, IL
    #4
    card slot?

    I don't remember, but doesn't the PBG4 have a card slot? If so you can get a replacement firewire connection (actually, two if I recall correctly) via that card slot. It is worth a try ...
     

Share This Page