The "iPhone 3.0 firmware broke my Wifi" thread

Discussion in 'iPhone Tips, Help and Troubleshooting' started by ToddJ, Jul 31, 2009.

  1. ToddJ macrumors 6502

    Joined:
    May 23, 2008
    #1
    so my wifi doesn't work. I updated to 3.0 and i think it worked fine, but after awhile my wifi no longer worked (or at would work for a little while and then would lose its connection.) Or sometimes it would 'forget' the password for my router. Has anyone found a solution to this problem? I have done the 'reset network settings' many, many, many times. I have also done a full restore and set it up as a new iphone, it didn't help. i did jailbreak my iphone with redsn0w and then unlocked it with ultrasn0w. I'm not sure if my trouble started then or not, so I was wondering if it might be the baseband.
     
  2. swoz macrumors newbie

    swoz

    Joined:
    Feb 21, 2009
    Location:
    Atlanta, Georgia
    #2
    I had this exact problem. The only thing I could do was to call Apple and send my phone in to be replaced.
     
  3. lansi23 macrumors member

    Joined:
    Jul 19, 2009
    #3
    get the phone replaced. i had mine replaced for the same issue, TWICE, within A WEEK. according to the counter, it is a known issue. i didnt ask further, just wanted a proper working unit.
     
  4. ToddJ thread starter macrumors 6502

    Joined:
    May 23, 2008
    #4
    has anyone tried beta 3.1? do you know if that fixes it? or do you know if 3.1 changes the baseband?
     
  5. ToddJ thread starter macrumors 6502

    Joined:
    May 23, 2008
  6. bruinsrme macrumors 603

    bruinsrme

    Joined:
    Oct 26, 2008
    #6
    Restored as a new phone, jailbroke, loaded all the themeing, SMS and other niceties jailbreak offers, then resynced my contacts using Funambol, synced movies, musicand videos then apps.
    Restoring from a backup resulted in having the same wifi issue.
    Restoring as a new phone the Wfi issues has not reapperared.
    One thing, make sure you save your pictures.
     
  7. 007bond macrumors 6502a

    007bond

    Joined:
    Dec 12, 2008
    Location:
    DFW, Texas
    #7
    it did break wifi but i did a restore and its all good now
     

Share This Page