The iPhone could not be synced because this computer is no longer authorized for purc

Discussion in 'iOS Programming' started by DavidCayce, Dec 3, 2013.

  1. DavidCayce macrumors newbie

    Joined:
    Dec 3, 2013
    #1
    I have an app in development and need to load the latest IPA for testing, a process performed through iTunes, like syncing anything else. When I try and sync I get the message, "The iPhone could not be synced because this computer is no longer authorized for purchased items that are on this iPhone."

    I did the research on the internet and haven't found an adequate answer. I've tried:

    — Being sure I'm logged into the same iTunes account as the iPhone.

    — Deauthorizing then Authorizing the computer, after which I get an alert saying the computer has been successfully authorized, resulting in the same error message again when I again try and sync.

    — Removing the SC Info folder, as found in this article: http://support.apple.com/kb/TS1389 . I guess I have the only Mac that has no trace af any such "SC Info" folder anywhere in the system (OS 10.6.8).

    — Logged in under every conceivable account configuration (computer admin, device account, etc...) to no avail.

    I have to get this IPA imported into the iPhone. It's the same process as syncing anything else. If anyone has a solution, please send it along. Clock is loudly ticking.

    Maybe a better question would be, Is there a way to import an IPA without using iTunes?

    Many thanks.

    Cayce
     
  2. xStep macrumors 68000

    Joined:
    Jan 28, 2003
    Location:
    Less lost in L.A.
    #2
    Apple Configurator maybe. I use it with enterprise signed IPAs at work.
     
  3. dejo Moderator

    dejo

    Staff Member

    Joined:
    Sep 2, 2004
    Location:
    The Centennial State
    #3
    I take it you don't have access to Xcode and the project that the app was built with. Has the IPA just been sent to you? Do you know if it's set up for ad-hoc distribution? Something else?

    If it's ad-hoc, I like to use a service called TestFlight to distribute my builds to beta testers. You might want to look into it.
     
  4. kimou75 macrumors newbie

    Joined:
    Mar 11, 2014
    #4
    i had the exact same problem
    i used a different apple id to download from itunes so i had a book or an app on that user
    i had to authorized with all user ids to make the sync work
     

Share This Page