The item cannot be copied because there is not enough free space

Discussion in 'MacBook Pro' started by willpower101, Sep 28, 2009.

  1. willpower101 macrumors regular

    Jul 12, 2009
    I get this message:
    "The item cannot be copied because there is not enough free space"
    Whenever I try to copy ANY file, even a 5kb text, from my mac desktop to one of two laptops. (BOTH, do the same thing)

    So then I try to put the files on a usb drive and do it that way.
    Same problem copying from the usb drive to either powerbook.

    So I try and mount the dmg from the usb drive, works, install folder opens. I run the installer, then it hangs on "examining drives" and all the drives are greyed out.

    Target disk mode lets me copy it over directly though.

    any ideas?
  2. maflynn Moderator


    Staff Member

    May 3, 2009
    How much space do you have on the target disk? Maybe its not letting you because there's no enough space.
  3. willpower101 thread starter macrumors regular

    Jul 12, 2009
    I would hope anyone asking this question acutally checked that first :D 24gigs

    P.s. - mounted and installed fine from the desktop copy in target disk mode after i rebooted. Still hinders me because I can't copy files any other normal method
  4. jt2ga65 macrumors regular

    Jul 1, 2007
    It sounds like a permissions issue that the OS is not interpreting correctly. Maybe try to repair the permissions?

  5. quantum003 macrumors 6502a


    Apr 27, 2009
    I had this happen to me once too. Maddening! One of your applications changed the permission settings of your hard disk I believe. If you right-click on it and select "view options", at the bottom is the lock and the permission settings. Can you authenticate and then click "ignore permission settings for this volume"? You may also try logging out of your computer and logging in as "Root" and trying this again.
  6. willpower101 thread starter macrumors regular

    Jul 12, 2009

    It's funny when you search for a problem and realize halfway through reading the answer that you're actually the Op. Lol.

    So any new ideas for why this doesn't work? I have two powerbooks attached via target disk mode and and I can't copy files between them because of this problem.
  7. jordann macrumors newbie

    Jul 31, 2010
    I was having this same problem for a long time (on and off, it was weird). I couldn't copy anything to my laptop and in the finder window it didn't show how much free space I had left. Now my laptop is pretty old now (Powerbook G4) and every time I boot it up it reverts to some date in 1969. I never made the connection until just now, when I connect it to my wifi and have the clock adjust automatically it fixed the transfer problem I was having and things started to show free space.

    So, I know it sounds stupid and like something that wouldn't help but it worked for me. Just make sure your date and time is set correctly on the laptops you were having trouble moving data to. :)
  8. varias macrumors newbie

    Aug 21, 2010


    You saved me!!! I have been trying to figure out how to transfer files from my old Powerbook G4 onto my new MacbookPro for about 3 hours. I tried 2 flash drives and even bought a new external because it kept saying I didn't have enough room to copy the files.

    I changed my date and time of my Powerbook which were set to 1970 and it worked. I had to comment and say thanks, you saved me!!! :D
  9. FarterTime macrumors newbie

    Jun 25, 2012
    I wish i read this 2 days ago. I feel so dumb:D
  10. lantzn macrumors newbie

    Jul 24, 2002

    I hadn't even noticed my date was out of sync. Changed it and everything is workingt again! I couldn't copy or delete files from my G4 running 10.5.8 to any thumb drive or external FW drive. That was very frustrating. Thank you.
  11. ekburgess19 macrumors newbie

    Aug 8, 2012
    Worked like a charm!

    Just to clarify, "right-click on it" means your hard drive in the side bar of the finder.

    Thanks quantum 003 - great advice, and saved me hours of trawling the internet!
  12. cesario09 macrumors newbie

    Dec 13, 2013

    Hey guys,

    I've tried this stuff but nothing seems to work for me. I'm still getting the error. I'm afraid I may not be doing it right. I can't get to "permissions" section that you're talking about. Maybe I'm being a little technologically challenged but can someone please give me detailed instructions???? I've been at this since 10am!!!!!!!!!!!!!
  13. Ccrew macrumors 68020

    Feb 28, 2011
    You haven't been here long obviously :)

    I've seen it where the destination didn't have correct permissions for write access from the origin. Process thinks the remote disc is full because the report back to origin is that it can't write.
  14. kreidol macrumors newbie

    Apr 6, 2018
    I too had this problem today. While I realize that my solution may not solve specifically for this case of transferring from laptop to laptop (I was looking for this same issue with dragging to an SD card), you might check that your laptop HDs have the same format. This is the first thing I thought could be wrong in my case and it was correct. Granted, this is a weird problem to have from mac to mac, and more common for a drive coming from a windows environment/format.

    For those of you having this issue with an external drive, like me with my SD card, I reformatted/Erased the SD card using Disk Utility as "ExFAT" and this allocated the SD card as a "USB Internal Physical Volume • ExFAT". This was the only format of four possible that worked. I can now drag and drop and copy the file over to the SD card.

    I hope some of this sends you down the path to finding an answer. Good luck.
  15. blackxacto macrumors 6502a


    Jun 15, 2009
    Middle TN
    you fixed my g4 iBook. copying to usb stick works

Share This Page

14 September 28, 2009