The Jailbreak Matrix

iphonewoman

macrumors member
Original poster
Jun 16, 2009
47
0
Hey guys and gals,

Been working on this Jailbreak Matrix for the iPhone / iPod Touch device.

Looks like this...



google "jailbreak matrix"
ps. will post a link once approved to do so by mod

Have about 60 hours into this one page, basically what it is, is a cross reference for all devices upto 3.1.3 to see if they are jailbreakable and unlockable and if so how to do it..

I've had input from ModMyI, HowardForums, iPodTouchFans and some other message boards, and now would like some input from you guys...

If you see anything thats off at all in my Matrix please let me know as i'm trying to keep it as neat as possible
 

WhatAmI

macrumors 6502a
Sep 2, 2009
919
10
Any initiative that minimizes confusion is a good initiaive. Kudos to you for sharing!
 

Pathfinder3

macrumors member
Feb 26, 2010
86
9
Okinawa, JP
That's great!

I think its safe to say that 2.0 - 2.2.1 is not needed in your matrix. I don't believe anyone is still rockin' those FWs on their iPhones nowadays..
 

labman

macrumors 604
Jun 9, 2009
7,776
1
Mich near Detroit
nice

need to add on 3GS that unless you are file with cydia there is no shsh option bot sure the best way to put it. but great sticky potential here! :D
 

iphonewoman

macrumors member
Original poster
Jun 16, 2009
47
0
^^^ i have that already

To jailbreak a iPhone 3GS on 3.1.3 you NEED to have your iPhone previously jailbroken and uploaded your SHSH to cydia, otherwise you wont be able to downgrade firmware and jailbreak, that is the only way. So if you want to restore to 3.1.2 you've had to backed up your SHSH on 3.1.2, get it ? But if you are not on 3.1.3 yet you can upgrade to 3.1.3 using custom jailbroken firmware, see guide below

That's great!

I think its safe to say that 2.0 - 2.2.1 is not needed in your matrix. I don't believe anyone is still rockin' those FWs on their iPhones nowadays..
yea mostly not but believe it or not i still have lots of clicks on that section, dunno why myself
 

ViViDboarder

macrumors 68040
Jun 25, 2008
3,447
0
USA
That's great!

I think its safe to say that 2.0 - 2.2.1 is not needed in your matrix. I don't believe anyone is still rockin' those FWs on their iPhones nowadays..
yea mostly not but believe it or not i still have lots of clicks on that section, dunno why myself
It's TheSpaz!! ;)

Also, I'm not sure if you fixed that typo in the screenshot you posted.

iPhone 3G 2.0.2 Download link has a /a> after download. Just a mixed up HTML tag :)
 

iphonewoman

macrumors member
Original poster
Jun 16, 2009
47
0
^^^^ refresh. :)


if there a mod that reads this, is it ok to put the link up to the site ?
 

kainjow

Moderator emeritus
Jun 15, 2000
7,745
3
if there a mod that reads this, is it ok to put the link up to the site ?
Seeing as your first post contained links to your website, and your second thread does too, I'm going to say no. Posting here just to promote your website is not allowed. Take this as your first and only warning.
 

iphonewoman

macrumors member
Original poster
Jun 16, 2009
47
0
Seeing as your first post contained links to your website, and your second thread does too, I'm going to say no. Posting here just to promote your website is not allowed. Take this as your first and only warning.
hey no problem i'm just here to help, i just started working for iphone3g-mods & jailbreak matrix, but have lots of info i can contribute... i will work my way to post a link its not a problem

first link was here
second link is a guide for how to tether an ipad to an iphone

guides i usually post a source on the bottom after posting the whole info here, i would never just come here to dump links...

this is a great forum and i wouldnt do nothing to jeopardize my membership
 

iphonewoman

macrumors member
Original poster
Jun 16, 2009
47
0
i added it for the old bootrom now thanks

what else is missing, i know there are 5 or 6 ways to jailbreak devices between all the software, im just pointing out a few
 

iphonewoman

macrumors member
Original poster
Jun 16, 2009
47
0
^^^ fixed new bootloader started to ship with 3.1 it was not out when 3.0 was out, so newbootloader + 3.0 = removed because it DNE
 

thelatinist

macrumors 603
Aug 15, 2009
5,933
49
Connecticut, USA
In your explanation of SHSH you make no mention of The Firmware Umbrella. It is not true that having your SHSH stored on Saurik's server is the only way to downgrade a 3GS' firmware; the SHSH can be stored locally using Umbrella even by people who have never jailbroken.

Also, it is not true that you need to have previously jailbroken to have your SHSH stored on Cydia. If you modify your hosts file to point to Saurik's server and restore to a valid firmware, your SHSH for that and all subsequent firmwares will be on file with Saurik even if you have never jailbroken. This is true of my wife's phone, which I upgraded to 3.1 using my computer with modified hosts file; she now has 3.1, 3.1.2, and 3.1.3 SHSHs on file with Saurik even though her phone has never been jailbroken.
 

lokster

macrumors 6502
Feb 7, 2010
364
2
to downgrade baseband on the 3g if the 5.08 bootloader is available you should add FUZZYBAND, you cant download ultrasnow if you havent fuzzyband
 

scirica

macrumors 68020
May 13, 2008
2,068
1
Dallas, TX
i added it for the old bootrom now thanks

what else is missing, i know there are 5 or 6 ways to jailbreak devices between all the software, im just pointing out a few
And therein lies the reason this attempt, while noteworthy, will fall short. Either list it all or don't do it and selectively decide which methods of jailbreaking should be listed.

A great start though!
 

iphonewoman

macrumors member
Original poster
Jun 16, 2009
47
0
to downgrade baseband on the 3g if the 5.08 bootloader is available you should add FUZZYBAND, you cant download ultrasnow if you havent fuzzyband
click the guide

it leads to fuzzyband, however ultrasnow is still the unlock tool thats why its listed there
 

iphonewoman

macrumors member
Original poster
Jun 16, 2009
47
0
In your explanation of SHSH you make no mention of The Firmware Umbrella. It is not true that having your SHSH stored on Saurik's server is the only way to downgrade a 3GS' firmware; the SHSH can be stored locally using Umbrella even by people who have never jailbroken.

Also, it is not true that you need to have previously jailbroken to have your SHSH stored on Cydia. If you modify your hosts file to point to Saurik's server and restore to a valid firmware, your SHSH for that and all subsequent firmwares will be on file with Saurik even if you have never jailbroken. This is true of my wife's phone, which I upgraded to 3.1 using my computer with modified hosts file; she now has 3.1, 3.1.2, and 3.1.3 SHSHs on file with Saurik even though her phone has never been jailbroken.
you still need to have it stored at the previous firmware for it to work, i will do more in depth reading on "umbrella" later tonight...

i reworded it for you for now :)