The local Barnes & Noble hates my Chromebook

Discussion in 'Community Discussion' started by GanChan, Dec 1, 2014.

  1. GanChan macrumors 6502a

    Joined:
    Jun 21, 2005
    #1
    About a week ago, the wi-fi server at my local Barnes & Noble coffee shop stopped working -- but only for me. I look around and see others happily working on their laptops (and online, as far as I can tell). My Samsung Chromebook, however, can't open the necessary connection page; it tries forever, then times out. I ran a connection test, and it seems to be stumbling at the firewall stage.

    All my other favorite hot spots around town continue to play nice with the Chromebook. It's just this ONE place that refuses to let me online.

    How should I troubleshoot this? What all can I try?

    Thanks!
     
  2. Mr_Brightside_@ macrumors 68030

    Mr_Brightside_@

    Joined:
    Sep 23, 2005
    Location:
    Toronto
    #2
    I could give you a number of suggestions for Mac OS, but they wouldn't help much. You might be better served asking this on a Chrome forum.
     
  3. thejadedmonkey macrumors 604

    thejadedmonkey

    Joined:
    May 28, 2005
    Location:
    Pennsylvania
    #3
    I found your problem ;)

    When I worked there, they used at&t for internet. I believe mcdonalds uses at&t, too. See if your chromebook works at mickydees, it may be an issue wth your laptop, but it may be an issue with at&t.

    The other things that might help, is try flushing your DNS, or rebooting while on the Barnes & Noble wifi network.
     
  4. localoid, Dec 1, 2014
    Last edited: Dec 1, 2014

    localoid macrumors 68020

    localoid

    Joined:
    Feb 20, 2007
    Location:
    America's Third World
    #4
    I have a Chromebook I use more frequently when I'm out than I do my Macbook or PC laptops. I never have a problem connecting with my Chromebook, provided the place's WiFi is working properly.

    Unfortunately, in my area, I find a lot of the public Wi-Fi networks are not working properly, but then I live in rural area, and I often am the only person in the place trying to use their Wi-Fi network. If I have problems, I usually ask someone working there if they can restart their wireless router and once they do this, it usually solves the problem. Other times, the employee rolls their eyes and says "Oh, it never seems to work." and then he/she mumbles something about "No one uses it anyway..." (Such is life in Podunk!)

    I almost always have my phone with me, so I can try logging onto the network with it. Typically, if I can't log on with my Chromebook neither can I log on with my phone.

    If I can't reach the connection page (like you mentioned in the OP), then usually the store's network connection to the outside world is completely down. A some places, that don't have a login screen, I often get a network connection but then the browser doesn't go anywhere when I type in a URL. In these cases, I sometimes find that switching to (using) "Google name servers" under the network tab solves the problem -- in other words the place's DNS server isn't working properly or hasn't been setup properly. See image below re: switching DNS:

    [​IMG]

    So, you could try that. Click on the bottom right of your screen and then click "settings", then click on the name of the network, which will bring up the panel shown in the image above. More detailed instructions here...

    Frankly, I'd suggest asking the management of the place if they know if their Wi-Fi is working properly, or check with someone else who's in the store with a laptop to see if they have a working connection. Or, if you have a smart phone (or another laptop) take it with you and see if you can get a connection with it. Unless you verify the Wi-Fi is working properly, you'll just be spinning your wheels trying to connect.

    For basic instructions on connecting to a network with a Chromebook -- go here -- or here (Can’t connect Chrome device to the network).
     

Share This Page