The 'N' key on my iPhone was broken.

Discussion in 'iPhone Tips, Help and Troubleshooting' started by mrkgoo, May 29, 2009.

  1. mrkgoo macrumors 65816

    Joined:
    Aug 18, 2005
    #1
    In landscape orientation was not giving me the feedback as in popping up the lttle icon to show that I had pressed it. I rebooted and now it's fine, but now my 'I' and 't' key is doing it! They can still be pressed. It's not hardware obviously. Oh weird. After I switch to the numerical keypad they are all fine. Wait now it's doing it for lowercase I's and t's. Like when I type. Iiiiiiiiiiiiiiiiiii I get the symbol popping up on the first 'I' only.

    What gives? Does anyone else have this happen? 3g iPhone 2.2.1/
     
  2. Drumjim85 macrumors 68030

    Drumjim85

    Joined:
    Oct 7, 2007
    Location:
    DFW, TX
    #2
    if you think it's just a software thing, then restore your phone.
     
  3. mrkgoo thread starter macrumors 65816

    Joined:
    Aug 18, 2005
    #3
    I did a second reboot and it seems fine now. It was very weird behaviour. Just trying to guess at what the software bug could have been! Maybe the image for the keys were not loaded correctly.

    Speaking of a restore, I have never done one. Do I lose settings? Do I have to resynchronise everything, of just the is?

    I also wish the iPhone had a spell checker built in. Whoops the 't ' just disappeared again.
     
  4. Drumjim85 macrumors 68030

    Drumjim85

    Joined:
    Oct 7, 2007
    Location:
    DFW, TX
    #4
    if you sync up your phone before you restore it, you will be able to use that backup to put everything back on your phone. But yes, you will have to wait for everything to re-sync.
     
  5. mrkgoo thread starter macrumors 65816

    Joined:
    Aug 18, 2005
    #5
    Thanks.

    I decided it is a bug in the 2.2.1 OS, as it happens with my iPod touch too.

    After some research, it appears to be an auto capitalisation bug, but only in safari, and only on a new webform, and only in a new session. Somehow it can get cumulative though.

    http://discussions.apple.com/thread.jspa?threadID=1942621

    To replicate the issue:

    Turn on auto-capitlisation.
    Start a new Safari session.
    Come to MacRumors, for example, and hit reply to a thread.
    Highlight the reply box.
    Repeatedly hit any letter key. The first will give the visual feedback, but the rest won't, but only if the auto caps kicked in and capitalised the first letter.
     
  6. thisisarcadia macrumors 6502

    Joined:
    Jun 26, 2008
    Location:
    New Orleans, LA
    #6
    there is no way a specific key couldnt work it may just be a bug in the software report it and restore to factory settings
     
  7. Gix1k macrumors 68030

    Gix1k

    Joined:
    Jun 16, 2008
  8. iFerd macrumors 6502a

    Joined:
    Jul 20, 2007
    #8
    I don't remember the specifics, but I've read before that this is an OS bug. I know I sometimes see that a tapped letter doesn't enlarge like it should. The letter gets entered, but the keyboard doesn't do its fancy visual feedback. I seldom use landscape orientation. I see this in portrait.
     
  9. mrkgoo thread starter macrumors 65816

    Joined:
    Aug 18, 2005
    #9
    I posted a link in my response above. It's related to auto-captilisation in OS 2.2. And yes, it happens in both orientations.
     

Share This Page