The operation cannot be completed because you do not have sufficient privileges!

Discussion in 'macOS' started by guapost, Nov 17, 2009.

  1. guapost macrumors newbie

    Joined:
    Nov 17, 2009
    #1
    Hi.

    I've done a complete re-installation af Snow Leopard.

    When trying to restore the library/mail folder via Time Machine i'm told: "The operation cannot be completed because you do not have sufficient privileges for "mail'" I seems to me that i have both privileges to read and write in the folder. I can't place the backed up files in a different folder either?

    I have no problems restoring my pictures and the likes from time machine?

    Hope that somebody can help me?

    Best regards Peter
     
  2. Sky Blue Guest

    Sky Blue

    Joined:
    Jan 8, 2005
  3. guapost thread starter macrumors newbie

    Joined:
    Nov 17, 2009
    #3
    In the Mac HD yes, not in time machine disk. Should I?

     
  4. r.j.s Moderator emeritus

    r.j.s

    Joined:
    Mar 7, 2007
    Location:
    Texas
    #4
    It can't hurt.
     
  5. guapost thread starter macrumors newbie

    Joined:
    Nov 17, 2009
    #5
    It's an external USB. Apparently not possible to repair permissions...
     
  6. mooblie macrumors 6502

    mooblie

    Joined:
    Apr 23, 2009
    Location:
    The Highlands, Scotland
    #6
    You can only repair permissions on bootable (i.e. System) drives.
     
  7. Scallywag macrumors regular

    Joined:
    Dec 21, 2007
    Location:
    NYC
    #7
    You can't restore individual files from a time machine backup, only a full system restore. You have to do it again, this time making copies of each folder you want to transfer over, separate from the time machine backup. Then drag them onto your new system one by one. I could never access photos, or music, or anything else from Time Machine, which is why I stopped using it.

    This has been my experience. For the OP's sake I hope I'm wrong
     
  8. guapost thread starter macrumors newbie

    Joined:
    Nov 17, 2009
    #9
  9. Scallywag macrumors regular

    Joined:
    Dec 21, 2007
    Location:
    NYC
    #10
    That link was to show that other have had the same trouble, unfortunately.

    I've never been able to change the permissions on the TM backup, though it's worth a try. Right-click the TM drive and go to 'get info.' You'll be able to try in there, but again it didn't work for me.

    Time Machine is designed for those who never want to worry about migrating files, etc., hence the complete lack of options and usefulness for anything else.
    It's misleading.
     
  10. cawas macrumors newbie

    cawas

    Joined:
    Jan 15, 2010
    #11
    A "much better" solution is using the terminal's cp (yes, short for 'copy'). Open time machine, copy the folder / file location under CMD+I and use something like this, for instance:

    Code:
    cp -R /Volumes/BACKUP/Backups.backupdb/MK\ MBP/2009-09-29-141056/Macintosh\ HD/Users/yourself/Documents "/Users/yourself/Documents"
    Amazing how, in my case, I didn't even need to use sudo and Time Machine still would bring me the "permission" bull.
     
  11. slycrel macrumors newbie

    Joined:
    Jul 11, 2008
    #12
    Thanks a ton cawas, This absolutely did the trick for me. It was a single app rather than the entire documents directory, but it worked great in the terminal. I had no idea you could do a cmd-i in time machine. =)
     

Share This Page