The Penryn Graphics Glitch.... on a Santa Rosa. On 10.5.3!

Discussion in 'MacBook Pro' started by jesstech, Jun 11, 2008.

  1. jesstech macrumors member

    Jun 12, 2007
    This has been happening periodically since the beginning of the week. Its symptoms include blocks of white 'flashes' while scrolling or watching video, along with graphical artifacts being left behind. To me, it sounds very much like the graphics glitches that plague the new Penryn MBPs; a glitch which 10.5.3 was supposed to fix.

    Here's a link to an article about 10.5.3 and the graphics glitch: 10.5.3, it points out, hasn't fixed a thing. In fact, judging from the comments and my own experience it's only gotten worse; what before was only a problem on Penryn-based MBPs is now a problem for me on my Summer 2007 Santa Rosa.

    I have never had a problem with graphics before installing 10.5.3 (besides the well-known 'Leopard Lag' in things like the 3D Dock and Exposé) and it only seems to happen while on battery power after returning from sleep.

    Is anyone else with a Santa Rosa (or even older) MBP noticing this now that you've installed 10.5.3?

    Attached Files:

  2. mrkgoo macrumors 65816

    Aug 18, 2005
    I thought this was related to the way Safari 3 rendered things.
  3. krisis1 macrumors member

    May 13, 2007
    Even Firefox does this on my SR (non-Penryn) MBP.
    Nothing to worry about, scroll a bit and it should be gone.

    If anyone has a fix, I'd like to know, but I learned to live with it. Sometimes quitting and restarting the application helps, if not try a reboot (geez, sounds like Windows, no?)
  4. Insulin Junkie macrumors 65816

    Insulin Junkie

    May 5, 2008
    Mainland Europe
    There's an uber long discussion on the apple support forums concerning that exact same glitch. (Most of those people have new 10.5.3 MBP's, as far as I can tell)

    I think I have a tuned down version of it, when I scroll with the bar the text on white background seems to flicker a tiny bit when I'm scrolling slow (but this only affects browsers). I just use the trackpad instead and haven't had the glitch on white backgrounds. The glitch doesn't happen at all when I scroll with the bar on any other background. It's strange, but a very minor glitch.

    Offhand though tons of people (judging by the amount of message boards this problem has been posted in) have the same or a similar problem to you, it's not your computer, it's highly probably a software glitch, and a common one at that.

    People have been speculating it to be a graphics card memory lag, and a driver firmware update would abolish this, who knows. Persisting problems when scrolling are known to apple though, if I understand correctly. It seems to be a common glitch, so wait it out. =) Their second attempt might do the trick.

    EDIT: None of the numerous solutions anyone suggested in that thread really worked, though re-booting helps for a while.
  5. jesstech thread starter macrumors member

    Jun 12, 2007
    I realize it's not my hardware, as this problem ONLY surfaced after installing 10.5.3. Curiously, it did not appear until just this past week; a week or two after 'upgrading.'

    In the past day, it's gotten worse. It now affects ALL video (blocks of flickering) regardless of type (though to varying degrees) even when not on battery power and is now guaranteed to leave artifacts when scrolling with the trackpad. Anything Webkit-based like Safari or Mail's preview pane seems to have it the worst. It happens only occasionally in Firefox.

    If I had to take a guess, I'd say there's a timing somewhere screwed up; the graphics card is drawing portions of the screen in the wrong place, so the OS must be giving it the wrong positions. This would explain why it's so prevalent when smooth-scrolling with the trackpad and nearly nonexistant when using the arrow keys instead: there's more to be updated and re-drawn, and faster, with smooth-scrolling.

    I'm going to try disabling/enabling Beam Sync and other graphics-related options and see if they offer any relief, but I'm not holding my breath.

    EDIT: Huh. Well I'll be; completely disabling Beam Sync seems to have fixed it. Or it could just be that I had to logout to restart WindowServer and something else got reset.

Share This Page