The Sims 3 "not supported on this architecture"

Discussion in 'Mac and PC Games' started by pkoch1, Jun 3, 2009.

  1. pkoch1 macrumors 6502a

    pkoch1

    Joined:
    Oct 3, 2007
    Location:
    Boston
    #1
    Hi!

    So I installed the Sims 3. I then installed the update. After that it wouldnt let me launch the application because "The Sims 3 is not supported on this architecture." The icon had a circle and a slash through it on top of the actual icon. (the no smoking sign) I reinstalled and got the same problem. I trashed the Sims and then reinstalled again. It worked this time. No problems.

    I played for a while, then quit when I was bored. Now it's giving me the same error message as before when I try to launch. Weird! I am running a 2009 Mac Pro with 10.5.7 if that helps. Any advice?
     
  2. genevieve.l macrumors newbie

    Joined:
    Jun 3, 2009
    #2
    I can't even install the sims 3, it's not working with my white macbook.
     
  3. voyagerd macrumors 65816

    voyagerd

    Joined:
    Jun 30, 2002
    Location:
    Rancho Cordova, CA
    #3
    It's working fine on my MBP. Did you let it update to version 1.1?
     
  4. ELMI0001 macrumors 6502

    ELMI0001

    Joined:
    Jan 5, 2009
    Location:
    Olympic Hills GC
    #4
    The icon doesn't mean anything - I get that when I install an app and launch it from a dock stack before running it.

    Weird about the brand new machine though ...
     
  5. masterofbuckets macrumors regular

    Joined:
    Apr 24, 2009
    #5
    Thats weird...are you sure u r installing it on a 10.5.7 partition ?

    try renaming your Sims 3 folder and the app itself too.

    Something like adding a '_' to the name of the app.

    Otherwise reinstall i guess.
     
  6. BittenApple macrumors 6502a

    BittenApple

    Joined:
    Nov 29, 2008
  7. ktdv1 macrumors newbie

    Joined:
    Jun 5, 2009
    #7
    same problem

    I am actually having the same error appear on my MBP. The weird part is that I successfully installed the game and played on Tuesday, and now it's Friday and it won't let me. Nothing on my computer has changed and my laptop fits all of the system requirements, even though my GeForce 8600M GT graphics card could be better.

    I repaired my permissions and volume as well to no avail. :(

    I guess the only next step is to reinstall?
     
  8. pkoch1 thread starter macrumors 6502a

    pkoch1

    Joined:
    Oct 3, 2007
    Location:
    Boston
    #8
    Yep

    I am sure its a 10.5.7 partition. I actually got it working by dragging the app out of the applications folder, and then back again. I'm just curious what causes this issue, and what the architecture issue is actually looking for so I can fix it.

    Did that too.

    Silly computers...
     
  9. bettykoyle macrumors regular

    Joined:
    Oct 23, 2008
  10. jcspeck macrumors newbie

    Joined:
    Nov 12, 2008
    Location:
    Texas
    #10
    I am having similar issues, I installed the game just fine, go to play and get the not supported message. Tried switching from better battery life to higher performance, no change. Late '08 mbp, 4 gigs ram, and nothing seems to be posted on EA's site. Anyone have a workaround?
     

Share This Page