The Sims Complete problem - please help!!!

Discussion in 'Mac and PC Games' started by Meredi5309, Jul 31, 2007.

  1. Meredi5309 macrumors newbie

    Joined:
    Jul 31, 2007
    #1
    I haven't opened the Sims Complete for Macs in a while, and after I tried to play it again, I get a message saying: "The path 'The Sims Complete.localized:The Sims" contains a slash (/), backslash (\), or period (.). Please remove the character from the appropriate Folder's name and try again." The problem is, I've never gotten this message before, and I don't see where exactly the folder is to correct this problem. When I try to find the folder in Sherlock, the path says " '/volumes/TheSimsComplete.localized/TheSims/. I have no idea how to get to this path and change the name. Help please ?!! Thanks

    I have a powermac G4 if that helps
     
  2. fredericksonrul macrumors newbie

    Joined:
    Feb 18, 2009
    #2
    I Found A Solution!!!!

    i think i may know how to fix this!!! i just figured it out. when you double click the cd icon for the game, at the bottom of the window it should say "copy the sims folder to your hard drive" or somthing like that. after its copied, go to your hard drive where you copied it and double click on the game icon. NOT THE GAME ICON WITHIN THE DISK!!! so...
    1. you copy (just drag it) the sims folder (found after double clicking the disk icon) to the hard drive.
    2. after copying, close all the windows you have open.
    3. with the disk still inserted, go to the hard drive (where you copied it) and open the sims folder.
    4. double click the icon for the game (your language)
    5. IT SHOULD WORK!!! YAY!
    hope i helped :)
     
  3. Newbsk8tr macrumors newbie

    Joined:
    Aug 5, 2009
    #3
    This worked for me

    First off, I'm running a brand new iMac with a 2.66 GHz Intel Core 2 Duo Processor running Mac OS X 10.5.7.

    I was also getting the "'The Sims Complete.localized:the Sims' contains a slash (/), backslash (\), or period (.). Please remove the character from the appropriate folder's name and try again." error message. I was worried that my computer was too new to run this game, but from other forum posts I was able to come up with what looks like a solution.

    I'm not saying this will work for everyone, but it seems to have worked for me -- at least no problems so far. Copy the "UserData" folder, which is in "The Sims" folder, from the disk onto your desktop. This should change the folder from "Read Only" to "Read and Write". Once that is done, copy the entire "The Sims" folder onto your desktop. Now open the "The Sims Complete" icon from the folder on your desktop. When I did this, the game ran.

    I hope it works for you, too (and continues working for me!).
     
  4. rj-300zx macrumors regular

    rj-300zx

    Joined:
    Feb 2, 2009
    #4
    Facepalm....


    Thats how you install things on Mac. I really hope you haven't done this before. If you have, you now know why most things never worked...
     
  5. M. Castille macrumors newbie

    Joined:
    Jan 6, 2010
    #5
    Really simple...

    I hate to point this out because I guarantee it will make us all feel stupid, but I had this exact problem and solved it by taking the period out from the name of my hard drive so it says "White Tiger 10 4" instead of "White Tiger 10.4"....

    Crazy, right? Worked like a charm the moment I changed it.
     

Share This Page