"There was a problem connecting to the server..."

Discussion in 'Mac OS X Server, Xserve, and Networking' started by TheLOGICalone, Apr 1, 2014.

  1. TheLOGICalone macrumors regular

    Joined:
    Jun 7, 2010
    Location:
    Jersey
    #1
    Hi, I tried searching all around for this issue and none of the suggested fixes worked for me. A couple years ago I went to a friends house and he transferred some files from his computer to mine, since then a message box persistently pops up saying
    "There was a problem connecting to the server "BrewStu Mac Pro"
    The server may not exist or it is unavailable at this time. Check the server name or IP address, check your network connection, and then try again.

    When it pops up the console reads:
    4/1/14 9:27:59.205 AM NetAuthSysAgent[1156]: DNSAddressResolver:Resolve CFNetServiceResolveWithTimeout failed
    4/1/14 9:27:59.205 AM NetAuthSysAgent[1156]: ERROR: AFP_GetServerInfo - connect failed 64

    I have tried:
    clearing server history
    i checked login items and the only one there is google drive and i recently added it

    My system
    2010 mac pro 3.3 6core 12gram gtx 680 (pc) ssdboot 1tb storage, 2tb time machine, ssd windows all internal
     
  2. TheLOGICalone thread starter macrumors regular

    Joined:
    Jun 7, 2010
    Location:
    Jersey
    #2
    as an update, (if anyone cares lol) I launched activity monitor and found "netauthsys agent" and force quit the process. This kills my problem dialog window for a significant amount of time, but then it comes back, I will try to see how much time and if I can possibly find out what is triggering it.
     
  3. vjb1976 macrumors newbie

    Joined:
    Jun 28, 2014
    #3
    There was a problem...

    I have this exact problem but I can't trace it back to what caused it or when it started. I have tried finding all occurrences of the server name in plist files and removing them. Still getting the problem with the exact console messages you posted. I'm hoping someone will have a fix because this is driving me mad!
     
  4. covertsonic macrumors newbie

    Joined:
    Jul 20, 2014
    #4
    I had the same problem. I opened an iPhoto library on my mac mini from my MBA via shared folders, and i started getting this popup you described. After various Google searches, I tried deleting system preferences from the library and I removed all login items; none of that worked.

    After another hour of frustration, I suspected that iCloud had something to do with it (when the error window popped up, i saw that iCloud Photos went to not responding on occasion in the Activity Monitor); so, I deactivated iCloud on my account completely (b/c just disabling photos alone didn't change anything) - by going to Apple->System Preferences->iCloud->Sign Out->Delete From Mac (all prompts). Then, I reactivated iCloud.

    After this, the popup "There was a problem connecting to the server "KTY Mac Mini" stopped completely. Let me know if this works for you.
     
  5. shaolindave macrumors member

    Joined:
    Jul 19, 2006
    #5
    Same Problem

    Same problem, but I still might be able to add to the convo.

    I have three Macs that I'm trying to network.
    - a 2014 iMac Retina (only about a week old)
    - a 2009 Macbook Pro
    - another iMac, I think it's a 2011, at my parent's house 100 miles away.

    While at my own house, the new iMac and the MBP can both connect to each other, no problem. They can also both connect to my parents remote iMac, no problem (I was having problems with my previous iMac but upgrading the Retina seems to have fixed that).

    Here's where it gets weird. When I take the MBP to the office, or to a friends house, both iMacs show up in the finder. I get this error when I try to connect to mine at home, but from both locations I can connect to my parents at their home just fine.

    I haven't visited my parents yet so I haven't been able to attempt to connect to my iMac or my MBP from their computer, remotely or locally.

    Since right now it's always my iMac that I can't connect to, and only remotely, it could be a problem with my router/modem setup.
     
  6. shaolindave macrumors member

    Joined:
    Jul 19, 2006
    #6
    Re: Same Problem

    Okay, a follow-up to the last comment:

    The problem and solution for me are both so weird it blows my mind. Hopefully this will help other people.

    The three macs all have different quirky names based on pop culture references. The one at my house (the one I can't connect to) was named after my favorite Ninja Turtle, "Raphael".

    I went to System Preferences, Sharing, and then changed the Computer Name from "Raphael" to "Raph". Now I can connect to it.

    I tried to rename it to a few different things. Most worked, I think at least one other didn't. When I tried changing the name back to "Raphael", it stopped working.

    So, I guess try changing your computer name?
     

Share This Page