Think I know the answer but confirming (3GS)

Discussion in 'Jailbreaks and iOS Hacks' started by gregnash, Jul 20, 2011.

  1. gregnash macrumors newbie

    Joined:
    Jul 20, 2011
    #1
    So my wife recently upgraded to the iPhone 4 and we planned on giving her old 3GS to her sister to use on T-Mobile network. We have done this in the past with our old iPhones and I even have my iPhone 4 (4.3.3 w/ 4.10.01 baseband) jailbroken.

    Anyways, during the wipe process I could not get the 3GS to restore to anything but 4.3.4 w/ 5.16.02 baseband. I have been trying for days to get it to restore to something else (4.3.3 and 6.15.00) so that I can unlock for her sister but to no luck. From reading everything, and receiving the "This device is not elgibile for the requested build" error I think I am SOL. I need a break/unlock that is reliable and untethered.

    Suggestions?
    iPhone 3GS, 4.3.4 Firmware, baseband 5.16.02 (or whatever the latest is). Would love to downgrade to 4.3.3 or 4.2.1 but everything I have tried (snowbreeze, pwngetool, redsnow) has failed with the same message.
     
  2. iFiend macrumors 65816

    Joined:
    Feb 28, 2011
    #2
    The only thing that you can do is update to the iPad baseband because 4.3.4 and its accompanying baseband are not unlockable.

    You may want to consider using one of the SIM hacks that are all over the place. Getting that to work would be a lot better than going to 6.15.00 and cocking up GPS, etc.
     
  3. gregnash, Jul 20, 2011
    Last edited: Jul 20, 2011

    gregnash thread starter macrumors newbie

    Joined:
    Jul 20, 2011
    #3
    Ok thanks for that.. I am not familiar with the sim unlocks because I have only ever used my phone on AT&T and my sister-in-laws phone was the OG iPhone that I jailbroke 2yrs ago and have not updated since.

    Oh and the GPS functionality is not all teh big of a deal because the sister-in-law does not have a data plan with T-Mobile so she doesn't use that part at all (unless she is connected to a wifi network).

    Mind explaining or pointing me to a good repository?
     
  4. Abs_p macrumors 6502a

    Joined:
    Jul 15, 2011
    #4
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_2_1 like Mac OS X; en-us) AppleWebKit/533.17.9 (KHTML, like Gecko) Version/5.0.2 Mobile/8C148 Safari/6533.18.5)

    Was this phone u talking about jailbroken before?
     
  5. gregnash thread starter macrumors newbie

    Joined:
    Jul 20, 2011
    #5
    Negative... Wife never wanted her phone jailbroken. Mine is however.
     
  6. Abs_p macrumors 6502a

    Joined:
    Jul 15, 2011
    #6
    Sadness :-(
    U Are stuck.
    Phone won't be able to be unlocked as there is no user friendly jb for 4.3.4 .. I don't advice u to update to iPad baseband coz of the jb. Try coaxing AT&T to unlock it for u. Say contract is over and u need to leave the country . I know a guy who got it unlocked.. But then he is the only one I hav known to get it done :p

    I strongly advice against updating to iPad baseband as u r on 4.3.4
     
  7. gregnash thread starter macrumors newbie

    Joined:
    Jul 20, 2011
    #7
    Ok that is what I was afraid of. Well guess she is either going to have to wait for a compatible JB/Unlock from Dev Team or just pick up a new phone from T-Mobile. Bummer thanks for the help guys.
     
  8. labman macrumors 604

    labman

    Joined:
    Jun 9, 2009
    Location:
    Mich near Detroit
    #8
    won't happen AT&T will not unlock in contract or out of contract maybe now that Apple is selling factory unlocks then maybe sometime in the future but not now. I suggest trading or selling it for a firmware that is unlockable or buying a factory unlocked 3gs. the sims people refer to like Gevey only work in the i4.
     
  9. Abs_p macrumors 6502a

    Joined:
    Jul 15, 2011
    #9
    Wont happen. But that was long back ;-)
     
  10. gregnash thread starter macrumors newbie

    Joined:
    Jul 20, 2011
    #10
    Ok here is the next question for you....

    I have been having some issues with my iphone 4 for the last few weeks (i.e. slow down, stuttering, changes in some things like ringer suddenly changing on its own and alarm not working) and I think I need to take it back and have it swapped out.

    I know I need to take a full back up of it and then save the shsh blobs with tinyumbrella. Once I take it back I am sure that the refurbed one they will give me will have 4.3.4 on it.

    So as long as I have the shsh blobs from Cydia and my restore with 4.3.3 I should be good to go right?
    Is there anything that I am forgetting to do?
     
  11. Carlanga macrumors 604

    Carlanga

    Joined:
    Nov 5, 2009
    #11
    Negative, if you are swapping phones then your older blobs won't be of any use for the new one. SHSH blobs are specific to the phone that they were saved to.
     
  12. labman macrumors 604

    labman

    Joined:
    Jun 9, 2009
    Location:
    Mich near Detroit
    #12
    shsh blobs are independent to each device or IMEI. I just exchanged mine last week with every shsh blob from 4.0.1 to 4.3.3 I now have only 4.3.3 and 4.3.4 saved. I'm guessing you will have 4.3.3 on your refurb they don't go through all the refurbs with each update. if it was independent to each device there would be no need for everybody to save them.
     

Share This Page