think I've tried everything to fix kernel panic

Discussion in 'MacBook Pro' started by alleyooptroop, Mar 5, 2016.

  1. alleyooptroop macrumors regular

    May 4, 2010
    I'll try to give all the details as succinctly as possible. I have an early 2011 15" macbook pro. It had started to randomly shut down/restart (which I found out was a kernel panic). I decided to give it a full overhaul:
    -installed new sandisk ssd (replaced the original spinning drive which I repurposed as a second drive to replace the super drive)
    -installed 16gb of ram
    -fresh install of of OS X El Capitan

    as soon as El Capitan was finishing up installing a kernel panic happened. So now I'm assuming it's not a software issue and probably not an issue with the hard drive or ram. As I'm typing (obvi on a different computer) I'm watching the little spinning icon. It doesn't look like it's going to fully boot up. Not really sure where to go from here other than bringing it to a specialist. Was hoping someone here would have suggestions on something else to try. Thanks in advance.
  2. throAU macrumors 603


    Feb 13, 2012
    Perth, Western Australia
    Could be a video card problem or system board failure.
  3. HDFan, Mar 6, 2016
    Last edited: Mar 6, 2016

    HDFan macrumors 65816

    Jun 30, 2007
    Did you check your kernel extensions?

    You can go to About This Mac/System/Report/Software/Extensions


    In a terminal window:

    kextstat -l | grep -v

    should show you all of the non-apple extensions. I was having some problems even after reinstalls but found some old extensions that were still being loaded. Went away after I removed them.

    You can also check:

    /System/Library/Extensions I think all of these are apple so I wouldn't touch.

    Be sure you know what you are doing if you remove them - could be very dangerous to your system!
  4. alleyooptroop thread starter macrumors regular

    May 4, 2010
    And this could happen with a fresh install of El Capitan?
  5. HDFan macrumors 65816

    Jun 30, 2007
    Depends upon how you define "fresh". If you completely wiped your hard disk, did the install, then restored your user data without installing any applications then yes, this would not apply.

    My "fresh" (sorry, maybe bad wording) was to reinstall El Capitan from my recovery disk since it would take me a week to reinstall all of my software.

    The checks above take just a minute or so so I'd check anyway in case something else installed itself as an extension.
  6. CoastalOR macrumors 68020


    Jan 19, 2015
    Oregon, USA
  7. alleyooptroop thread starter macrumors regular

    May 4, 2010
    Thanks CoastalOR. I'll have them check it out. I tried wiping the ssd again and reinstalling the os, this time back down to mavericks. Same thing happens when I try to shut down - kernel panic. here's the problem details:

    Anonymous UUID: 39A33D95-7418-05CA-80C9-E4CE603F12FE

    Sun Mar 6 12:30:46 2016
    panic(cpu 2 caller 0xffffff7f8e46ceaa): "AGC GPU REGISTER RESTORE FAILED : rdar://7254528, VendorID invalid"@/SourceCache/AppleGraphicsControl/AppleGraphicsControl-3.6.22/src/AppleMuxControl/kext/AGCPowerManagement.cpp:1114
    Backtrace (CPU 2), Frame : Return Address
    0xffffff81f6473de0 : 0xffffff800ca22f79
    0xffffff81f6473e60 : 0xffffff7f8e46ceaa
    0xffffff81f6473ea0 : 0xffffff7f8e46f650
    0xffffff81f6473ec0 : 0xffffff800ceb359b
    0xffffff81f6473f20 : 0xffffff800ca4a20a
    0xffffff81f6473fb0 : 0xffffff800cad7607
    Kernel Extensions in backtrace:[32862231-50BC-3AF6-87A2-703321AE4F90]@0xffffff7f8e461000->0xffffff7f8e474fff

    BSD process name corresponding to current thread: kernel_task

    Mac OS version:

    Kernel version:
    Darwin Kernel Version 13.4.0: Sun Aug 17 19:50:11 PDT 2014; root:xnu-2422.115.4~1/RELEASE_X86_64
    Kernel UUID: 9477416E-7BCA-3679-AF97-E1EAAD3DD5A0
    Kernel slide: 0x000000000c800000
    Kernel text base: 0xffffff800ca00000
    System model name: MacBookPro8,2 (Mac-94245A3940C91C80)

    System uptime in nanoseconds: 1756857120576
    last loaded kext at 249624106589: 1.9 (addr 0xffffff7f8eeaf000, size 65536)
    last unloaded kext at 1672626264909: 3.6.0 (addr 0xffffff7f8d4d2000, size 69632)
    loaded kexts: 4.2.7f3 1.9.5d0 1.60 3.0 1.0.0d1 3.5.13 100.14.34 124 1.2.4 8.2.4 2.6.3f4 7.0.0 2.6.3f4 1.2.4 1.1.2 4.2.7f3 1.0.0 3.8.1b2 700.20.22 2.0.4d1 1 3.6.22 1.7.0 1.2.4 1.0.0 8.2.4 1.2.5 3.0.4d1 240.2 240.2 325.7 1.0.0d1 1.0.0d1 1.0.0d1 35 404 683.4.0 2.6.0 1.5.2 5.0.2 3.0.5 660.4.0 161.0.0 2.0 2.0 1.8 2.1 2.0 1.7 217.92.1 153 3 217.92.1 10.0.7 1.0 91.1 2.6.3f4 1.0.0 1.9.7fc2 1.14 4.2.7f3 98.23 4.2.7f3 1.0.3b4 1.0.1b5 2.6.3f4 2.6.3f4 640.36 2.2.6 3.2 1.0.4 2.4.1 3.6.22 1.0.12d1 1.2.4 3.6.22 1.0.0 5.7.1d6 1.0.12d1 2.4.1 3.1.8 3.1.7 3.1.7 1.4.5 3.6.7 240.10 660.4.0 380.70.2 650.4.0 656.4.1 2.0.1 3.3.1 660.4.2 4.5.5 2.6.5 686.4.1 2.0 2.0 2.0.0 1.1 278.11.1 1.0.0d1 7 2 371.1 1.9 23 28.30 2.0 2.9 1.4 1.0 1
    Model: MacBookPro8,2, BootROM MBP81.0047.B2C, 4 processors, Intel Core i7, 2.2 GHz, 16 GB, SMC 1.69f4
    Graphics: Intel HD Graphics 3000, Intel HD Graphics 3000, Built-In, 512 MB
    Graphics: AMD Radeon HD 6750M, AMD Radeon HD 6750M, PCIe, 1024 MB
    Memory Module: BANK 0/DIMM0, 8 GB, DDR3, 1600 MHz, 0x859B, 0x435438473353313630424D2E4D3136464E00
    Memory Module: BANK 1/DIMM0, 8 GB, DDR3, 1600 MHz, 0x859B, 0x435438473353313630424D2E4D3136464E00
    AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0xD6), Broadcom BCM43xx 1.0 (
    Bluetooth: Version 4.2.7f3 14616, 3 services, 23 devices, 1 incoming serial ports
    Network Service: Wi-Fi, AirPort, en1
    Serial ATA Device: SanDisk Ultra II 960GB, 960.2 GB
    Serial ATA Device: TOSHIBA MK7559GSXF, 750.16 GB
    USB Device: FaceTime HD Camera (Built-in)
    USB Device: Hub
    USB Device: BRCM2070 Hub
    USB Device: Bluetooth USB Host Controller
    USB Device: Apple Internal Keyboard / Trackpad
    USB Device: Hub
    USB Device: IR Receiver
    Thunderbolt Bus: MacBook Pro, Apple Inc., 22.1

    this is way beyond my knowledge. would the above indicate whether I am experiencing what CoastalOR mentioned?
  8. treekram macrumors 65832

    Nov 9, 2015
    Honolulu HI
    The panic and the backtrace would strongly implicate the GPU so I would agree with CoastalOR. Your time would be better spent getting that looked at first before trying other things.
  9. CoastalOR macrumors 68020


    Jan 19, 2015
    Oregon, USA
    The kernel panic does show the GPU was involved. Definitely make an appointment to have Apple test it.

Share This Page