Third party keyboard randomly reverts to default

gordon1234

macrumors 6502a
Original poster
Jun 23, 2010
571
162
When using third party keyboards, I'm noticing that periodically it will just switch back to the default iOS keyboard. Not while I'm actively using it, but I'll open an app and it will have just reverted. This seems to happen about 10 times a day. Has anyone else noticed this behavior?
 

eddiec312

macrumors 6502
Jul 19, 2008
360
7
Miami, FL
When using third party keyboards, I'm noticing that periodically it will just switch back to the default iOS keyboard. Not while I'm actively using it, but I'll open an app and it will have just reverted. This seems to happen about 10 times a day. Has anyone else noticed this behavior?
Remove the keyboard "English (US)" from your keyboards.
 

Shaqq

macrumors regular
Jan 17, 2014
197
1
Yea its been happening alot to everyone including me. Like the person above me said remove english keyboard and it doesn't happen. Hopefully it'll be a fix for it soon hopefully in IOS 8.0.1.
 

firedoug

macrumors newbie
Sep 17, 2014
4
0
I believe this is an Apple security feature to only use native keyboard for entering usernames, passwords, credit cards and such. Apple is doing this to prevent the third party keyboards from capturing keystrokes.

Regards
 

gordon1234

macrumors 6502a
Original poster
Jun 23, 2010
571
162
I believe this is an Apple security feature to only use native keyboard for entering usernames, passwords, credit cards and such. Apple is doing this to prevent the third party keyboards from capturing keystrokes.

Regards
You're correct that there is a security feature that does this (and for good reason.) However, it's only for secure text fields (e.g., the ones where your typing just appears as dots.) The regular keyboard comes up when accessing these fields, but it normally reverts back to your selected keyboard when you select a non-secure field. The issue myself and others are having is that the keyboard just randomly switches back to the default keyboard for all text fields.

I'm going to try what others suggest and remove the default keyboard. Hopefully that will do the trick until Apple fixes the bug.
 

gorenut

macrumors member
Jan 10, 2007
41
0
I actually came back to this forum to see if anyone else was having this issue. Glad to see I'm not alone.

Remove the keyboard "English (US)" from your keyboards.
Thanks, I'll try this.

----------

Seems like it's working now. I'll test it out all day tomorrow to see if it stays consistent
 

ross1998

macrumors 6502a
Jan 10, 2013
952
196
This happens because you guys kept English(US) keyboard as your first one which gives it priority over the keyboards below it. Either delete English keyboard or put your third-party keyboard on top of English(US).

I deleted the English US keyboard off my keyboards and my phone uses SwiftKey every single time. Haven't seen the stock keyboard since deleting it.
 

Vetvito

macrumors 6502a
Sep 30, 2012
529
8
And sometimes.... When u try to respond to a text message using quick reply, no keyboard shows up at all.

Then when I open the messages app, the keyboard is non responsive.

I've deleted the English keyboard, and it still does this.
 

eddiec312

macrumors 6502
Jul 19, 2008
360
7
Miami, FL
And sometimes.... When u try to respond to a text message using quick reply, no keyboard shows up at all.

Then when I open the messages app, the keyboard is non responsive.

I've deleted the English keyboard, and it still does this.
These are known bugs with Swiftkey. Happens to me also. Devs are aware and are working on fixes they said.
 

xcrunner

macrumors regular
Dec 17, 2007
186
0
This happens because you guys kept English(US) keyboard as your first one which gives it priority over the keyboards below it. Either delete English keyboard or put your third-party keyboard on top of English(US).

I deleted the English US keyboard off my keyboards and my phone uses SwiftKey every single time. Haven't seen the stock keyboard since deleting it.
I sometimes get the Emoji keyboard randomly now lol. Clearly some SwiftKey and/or iOS 8 issue that hopefully will be fixed.
 

phillytim

macrumors 65816
Aug 12, 2011
1,346
658
Philadelphia, PA
Being so fresh from the launch of iOS 8 and the first time out of the gate for these keyboards, I'm sure these foibles are just a part of the break-in process and that they will be tweaked up with updates soon.

My SwiftKey appears to be working pretty reliable, as I expect, for me thus far, I'm grateful to report.
 

Pagemakers

macrumors 68030
Mar 28, 2008
2,507
843
Manchester UK
To replicate the problem, when using another keyboard press the globe button to invoke an emoji, then you decide not to use an emoji and press the globe icon again - your keyboard now changes to something else.
 

Black Magic

macrumors 68020
Sep 30, 2012
2,231
908
Yea, I experienced all the issues in this thread. Im starting to see that it's really not worth the hassle and the default keyboard is fine. Plus I don't have to concern myself with key logging as a bonus.
 

gorenut

macrumors member
Jan 10, 2007
41
0
Ya second day trying out after removing the English keyboard and seems like Swype gets brought up by default with no issues
 

Black Magic

macrumors 68020
Sep 30, 2012
2,231
908
Ya second day trying out after removing the English keyboard and seems like Swype gets brought up by default with no issues
Wait until you do a quick reply and notice that the emoji keyboard is now your default.....
 

Iamgort

macrumors regular
Aug 27, 2011
121
4
Yea its been happening alot to everyone including me. Like the person above me said remove english keyboard and it doesn't happen. Hopefully it'll be a fix for it soon hopefully in IOS 8.0.1.
Removing the default english did not fix it for me. It still defaults to the original keyboard until I hit the globe then it goes to swiftkey.
 

gordon1234

macrumors 6502a
Original poster
Jun 23, 2010
571
162
Wait until you do a quick reply and notice that the emoji keyboard is now your default.....
It seems like the issue is that Apple blocks third-party keyboards from loading when the phone is locked. (third-party keyboards load fine in quick reply if the phone is unlocked, at least for me.)
If you try to do a quick reply from the home screen and the built-in keyboard is disabled, then you get the only other active built-in keyboard (Emoji, for most people.) Disabling third-party keyboards when the phone is locked is probably intentional on Apple's part, but clearly the default keyboard should come up when third-party keyboards are blocked, regardless of whether it's enabled or not.
 

Zaft

macrumors 601
Jun 16, 2009
4,077
3,283
Brooklyn, NY
It seems like the issue is that Apple blocks third-party keyboards from loading when the phone is locked. (third-party keyboards load fine in quick reply if the phone is unlocked, at least for me.)
If you try to do a quick reply from the home screen and the built-in keyboard is disabled, then you get the only other active built-in keyboard (Emoji, for most people.) Disabling third-party keyboards when the phone is locked is probably intentional on Apple's part, but clearly the default keyboard should come up when third-party keyboards are blocked, regardless of whether it's enabled or not.
kind of defeats the purpose of having these keyboards if apple is going to be so restrictive.
 

platoaddict

macrumors newbie
Sep 12, 2014
18
0
I didn't have any problems with this with iOS 8 on my iPhone 5. Today, I received my iPhone 6. I only have one keyboard installed (first it was Swype, now it is Swiftkey). It works in safari, but in iMessage it is reverting to the English keyboard, which isn't even installed.

Anyone else experiencing this or have thoughts on how to fix it? Reboots haven't worked, and I'd rather not start with a clean install :eek:
 

Jason Cox

macrumors member
Aug 23, 2012
30
11
Dallas, TX
FYI guys, us developers have the ability to turn off Extensions such as third party keyboards in our apps. So in the future you may lose your keyboards in certain apps if they're not supported. You'll not only be switched back to the default keyboard, but your third party keyboard won't even show up inside the app if we devs choose to not support it.
 

Dmaynard83

macrumors 6502a
Jul 16, 2012
825
66
FYI guys, us developers have the ability to turn off Extensions such as third party keyboards in our apps. So in the future you may lose your keyboards in certain apps if they're not supported. You'll not only be switched back to the default keyboard, but your third party keyboard won't even show up inside the app if we devs choose to not support it.

One less reason to use your app if we can't use our keyboard in it.
 

platoaddict

macrumors newbie
Sep 12, 2014
18
0
FYI guys, us developers have the ability to turn off Extensions such as third party keyboards in our apps. So in the future you may lose your keyboards in certain apps if they're not supported. You'll not only be switched back to the default keyboard, but your third party keyboard won't even show up inside the app if we devs choose to not support it.
That's good to know but doesn't address the fact that the bug that I'm seeing is that the keyboard is not appearing in system apps. for me, I can get the keyboards to work in Safari but no longer in iMessage or Mail.
 

Surf Monkey

macrumors 68030
Oct 3, 2010
2,687
474
Portland, OR
Notice that if you accidentally single tap the globe icon the keyboard will instantly switch to the next one in order on the list of available keyboards. This is a behavior that may be causing some of the confusion and one that should probably change in a future iOS release. The keyboard switcher should only be invoked if you long press it.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.