"This accessory is not made to work with iPhone"

Discussion in 'Jailbreaks and iOS Hacks' started by converge, Nov 4, 2009.

  1. converge macrumors member

    Joined:
    Aug 4, 2009
    #1
    Is there a jailbreak solution to removing this message when a 3rd party device is connected to the dock?

    [​IMG]
     
  2. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #2
    Yes, but when I sent the commands thru Mobile Terminal not to send the warning, it caused my iPhone to stop recognizing the device/cable, so I couldn't even use the cable.

    I had to go back into Mobile Terminal and undo everything I had just done.

    I would recommend just putting up with it, if you need to use the device on your phone.

    From DevTeam

    Accessory not supported

    If you get popups like this every time you plug in your accessory or charger, try issuing this command from a login shell:

    /bin/launchctl unload -w /System/Library/LaunchDaemons/com.apple.accessoryd.plist

    If you ever want to put that daemon back in place – it's probably there for a reason – do this:

    /bin/launchctl load -w /System/Library/LaunchDaemons/com.apple.accessoryd.plist

    http://wikee.iphwn.org/howto:random#accessory_not_supported
     
  3. undergroundHACK macrumors regular

    Joined:
    Sep 9, 2009
    #3
    I agree it's annoying. After all, the device I purchased stated it supported the iPhone 3G on the box!
     
  4. thundermustard macrumors regular

    Joined:
    Apr 21, 2008
    #4
    It does time out and leave your iPhone on after a while.
     
  5. chargit macrumors 6502a

    chargit

    Joined:
    Jan 17, 2010
    Location:
    Evansville, In
    #5
    ok I have ready this problem many times on here and I just had my first iPhone give me this error. I could not respond before because I had never actually seen it. now after reading hundreds of posts many of you are actually on to it by saying a drop of water, or dust in the charging port. this is definaltely the problem. it is not the device that you are plugging into it because in this case the phone was not plugged in and still did it. so I replaced the dock assembly which houses the charging cable, speaker, mic, etc. and it solved the problem instantly. it turns out the connector in the phone I was working on had a pink water sensor. replaced it and BAM! :D

    good luck!
     
  6. thelatinist macrumors 603

    thelatinist

    Joined:
    Aug 15, 2009
    Location:
    Connecticut, USA
    #6
    You can safely get rid of this message using Popup Blocker from Cydia. It will block all kinds of annoying popup messages. I've got a Griffin iTrip which gives me this message ever time I plug it in, but it works fine and Popup Blocker got rid of the annoying Airplane mode message that used to pop up every time I plugged it in. I think it's a couple of bucks, but well worth it.
     
  7. Bdubb macrumors regular

    Bdubb

    Joined:
    Mar 18, 2010
    #7
    On a similar topic, but a different kind of "Pop Up"

    I wanted to install the "Ultrasn0w" source on Cydia (thinking that I can use it to Unlock my 3.1.2 with 5.11.07 bb. :p)

    I made the common mistake of typing the address "http://repo666.ultrasn(o)w.com" with a "o" (oh) instead of a "0" (zero).

    So every time I load up Cydia I get this stupid ERROR Message!

    [​IMG]

    How do I tell Cydia to forget about that link and to stop trying to connect to it?:confused:

    I went to "manage" to delete the specific source or whatever, turns out it doesn't exist...(and I cannot even delete the actual "repo666.ultrasn0w" source either)
    [​IMG]



    I have no way of stopping this, it is getting annoying every time I run Cydia to see this pop-up.:mad:

    I don't want to restore and re-jailbreak my iPhone just for this stupid pop-up, I hope there is a less drastic way to get rid of it, anyone? please... thanks in advance
     
  8. thelatinist macrumors 603

    thelatinist

    Joined:
    Aug 15, 2009
    Location:
    Connecticut, USA
    #8
    Bdubb: this is really a completely different topic, and in future you should make a separate thread (although this has been asked before...)

    You need to check each of the files in /etc/apt/sources.list.d for the offending entry. If you find a file that contains only that entry, delete the file; if it contains other repositories, edit it to remove the misspelled one.
     
  9. Bdubb macrumors regular

    Bdubb

    Joined:
    Mar 18, 2010
    #9
    Sorry thelatinist...but I am quite cautious about starting new threads after getting this hammering....

    http://forums.macrumors.com/showthread.php?t=880914&highlight=bdubb

    And to find old topics about small specifics around here is quite hard.

    I figured a pop up is a pop up!.

    EDIT:

    Ok file edited, stupid false link removed! thanks once again, The one and only Latinist!

    [​IMG]


    EDIT: Ok I think things are ok...:confused::(:eek:
     
  10. krypt17 macrumors member

    Joined:
    Jan 26, 2010
    #10
    I've been getting the same error popup on my 3G for the past 2 days. It started to happen in the middle of the day. I took my phone up to the apple store and they gave me a new replacement. I woke up this morning and the same error popped up on the new iPhone. There does not appear to be the slightest look of any damage caused by the docks I use. I don't want to resort to jailbreaking for a fix. Is there another way to fix this? Is it possible an update to an app had some bugs and can cause this?
     
  11. csmitty macrumors regular

    Joined:
    Sep 15, 2007
    #11
    Mine does the same with the power jolt se charger. Worked fine when I got the 3G. But seems after 3.0 is when I get the message everytime I plug it. I can cancel and it still works. However sometimes the battery drains even when its plugged in! or will charge some then stop, give the full bat. icon even when its not. then charge some more. very strange. does it on all my 12V plugs. Message comes up on a non JB 3G as well. Can't confirm wacky charging though.
     
  12. krypt17 macrumors member

    Joined:
    Jan 26, 2010
    #12
    I don't even have anything plugged into it.. I dunno.. Can't be hardware if I just got a new one..
     
  13. RNVarma macrumors regular

    Joined:
    Feb 4, 2010
    #13
    I can "second" thelatinist's suggestion of Popup Blocker. You can use it to block various other popups as well, e.g. low battery warnings, airplane mode warnings, and voice mail warnings.

    I highly recommend Popup Blocker.
     

Share This Page