"This app is currently being modified"

Discussion in 'iPad' started by itsjustmeee, Feb 11, 2012.

  1. itsjustmeee macrumors 6502a

    Joined:
    Dec 28, 2008
    #1
    I've been getting "This app is currently being modified. Please try again later" a lot lately when I try to download an app from my ipad. Does anyone have any idea why this happens and how to avoid it?
     
  2. Cynicalone macrumors 68040

    Cynicalone

    Joined:
    Jul 9, 2008
    Location:
    Okie land
    #2
    That usually means it is either being updated on the servers or the price is being changed.
     
  3. itsjustmeee thread starter macrumors 6502a

    Joined:
    Dec 28, 2008
    #3
    That's what I thought at first, but I've seen apps that have that same message 2 days later.
     
  4. zp3dd4 macrumors member

    Joined:
    Jun 21, 2009
    #4
    Try gifting the app to yourself. This will sometimes allow the app to be purchased.
     
  5. kalsta macrumors 68000

    kalsta

    Joined:
    May 17, 2010
    Location:
    Australia
    #5
    It's not just you itsjustmeee. (Sorry, just had to say that.) This has started happening to me in the last week or two, and like you say, days later the same app reports the same message.

    I contacted Apple Support about it, but they have not been helpful. All their replies basically boil down to 'Try again later. Have a nice day!' I'm still having this out with them—if I get anywhere I'll let you know!

    Oh and please… lodge a support request with them too. It may be that the only way to get them to take the issue seriously is if enough people like you and me complain about it.

    ----------

    BTW, there's a growing thread about this on Apple's support forum:

    https://discussions.apple.com/message/17503665#17503665
     
  6. Vindicator macrumors member

    Joined:
    Mar 20, 2011
    #6
    yes, I have the same problem. I also notice its mostly happen when download app current change the price to free (Apps Gone Free on appadvice.com :D), other free apps still download just fine.
     
  7. Nokaoi macrumors regular

    Joined:
    Feb 14, 2009
    #8
    (╯°□°)╯︵ ┻━┻

    Just tried to download GTA 3 to no avail.
     
  8. slayorktc macrumors newbie

    Joined:
    Nov 29, 2012
    #9
    What fixed it for me

    I was able to fix this issue by finding the app that was in conflict in the app store and then click the update button from there. So the same button where you clicked "Buy" when you are looking at a particular app, this time it will say update. It must have been an issue when trying to update from the app store update tab.. Strange but that seemed to fix the issue for me.
     

Share This Page