iPhone "This device isn't eligible for the requested build"

Discussion in 'iOS 6' started by DC1544, May 15, 2013.

  1. DC1544 macrumors newbie

    Joined:
    May 15, 2013
    #1
    Dear all,

    I'm new to smartphones and recently purchased a 64Gb iPhone 4s on ebay (in hindsight a silly thing to have done).

    After getting sick and tired of iTunes asking me to update the phone, yesterday I ran the update. After this had been done Apple locked the phone and iTunes told me I needed to "restore" it.

    When I then tried to restore I got a message, "The iPhone could not be restored. This device isn't eligible for the requested build." The phone is therefore completely inoperable.

    Is anybody able to let me know why I have this problem (I assume the phone isn't correctly registered or something) and if/how it can be rectified?

    Any feedback greatly appreciated.

    Many thanks,
    DC
     
  2. Zmanbaseball2 macrumors 68040

    Zmanbaseball2

    Joined:
    Aug 24, 2012
    Location:
    New York, USA
    #2
    You can only update to ios 6.1.3. Anything lower is not being signed.


    Sent from my iPhone 5 using Tapatalk 2
     
  3. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #3
    • Make sure your host file is pointed to Apple, not Cydia.
    • Make sure you have newest iTunes installed.
    • Recommend you let iTunes get the correct IPSW instead of manually downloading it.

    Perhaps you bought a device with hardware damage :eek:
     
  4. DC1544 thread starter macrumors newbie

    Joined:
    May 15, 2013
    #4
    Thanks very much folks! The phone is working again now.
     

Share This Page