This happened to my trusty 23 inch Cinema Display

Discussion in 'Mac Accessories' started by phoneorpda, Mar 16, 2012.

  1. phoneorpda macrumors regular

    Joined:
    Sep 7, 2005
    Location:
    All around the world.
    #1
    Hello all,

    after years of great service, i am left with a damaged Cinema Display...

    the one of the plugs that comes out of the back (not usb, not firewire...dvi i guess?) and plugs in the brick has broke off...see attachments.

    I consulted with local repair stores and the apple store, and the minimum charge for this is going to be 550$... i can't seem to find any other solution, besides from a whole cable assembly on eBay for 100$, but then again i'd have no idea of how to install it myself.

    I use the monitor connected to a 2009 Nehalem octo.

    Any suggestions?

    Thanks in advance...it is really appreciated!
     

    Attached Files:

  2. peskaa macrumors 68020

    peskaa

    Joined:
    Mar 13, 2008
    Location:
    London, UK
    #2
    It plugs in to the brick? You've snapped the power lead.

    Solution? New display or the whole lead assembly. I wouldn't try soldering that back together, way too easy to get wrong and fry the whole display. However, if you don't know how to fix it yourself even with the correct parts, you're back to looking for a new display I'm afraid.
     
  3. JesterJJZ macrumors 68020

    JesterJJZ

    Joined:
    Jul 21, 2004
    #3
  4. cosmicjoke macrumors 6502

    Joined:
    Oct 3, 2011
    Location:
    Portland, OR
    #4
    sucks, is definitely a fear of mine w/ my thunderbolt displays... is mind boggling to me how the cables aren't detachable from the display...
     
  5. ELA2 macrumors member

    Joined:
    Apr 21, 2011
    #5
    Wirelessly posted (Mozilla/5.0 (iPhone; CPU iPhone OS 5_1 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9B176 Safari/7534.48.3)

    I think the tb cable is detachable from inside
     

Share This Page