"This iPhone couldn't be restored. Not Eligible for requested build" error?!?!!?

Discussion in 'Jailbreaks and iOS Hacks' started by bella92108, May 6, 2011.

  1. bella92108 macrumors 68000

    Mar 1, 2006
    So iTunes prompted me to update my iPhone 4 to 4.3.3 (I have canadian factory unlocked iphone 4 on 4.3.2), but when I tried to UPDATE, I got the attached message, and so I downloaded the 4.3.3 IPSW and tried to manually RESTORE to it, and got the same message. Any idea what's going on?

    Attached Files:

  2. bella92108 thread starter macrumors 68000

    Mar 1, 2006
    OOPS! Forgot about hosts file.. for others having the issue:

    Check your hosts file to make sure gs.apple.com is commented out. It's a file that the operating system uses to resolve domain names to IP addresses.

    On Windows it's located at C:\Windows\system32\drivers\etc\hosts
    On Windows 7 you might need to Right-click on Notepad and 'run-as administrator' to be able to edit the file. Then browse to C:\Windows\system32\drivers\etc.

    In OSX it's located at /private/etc/hosts
    The best way to edit the file here is run the following from the terminal app
    sudo nano /private/etc/hosts
    When it asks you for your password use the same on you use to log into the system.
    Add a # before the gs.apple.com
    Press Control O to save, hit enter, and control X to exit the editor
  3. bmms8 macrumors 68020

    Dec 19, 2007
    same problem here. i read some people had the same problem over at the dev blog site. luckily my phone came out of DFU mode, i will update to 4.3.3 when they have this resolved. i think its something to do with pwnage tool. unless the link they gave us for the download was actually not the iphone 4 gsm ipsw.
  4. bella92108 thread starter macrumors 68000

    Mar 1, 2006
    Look at my reply, I forgot about the hosts file... resolved :)
  5. bmms8 macrumors 68020

    Dec 19, 2007
    brian posted directions in the jb 4.3.3 thread. good luck
  6. bmms8 macrumors 68020

    Dec 19, 2007
    now this thread doesnt make any sense... it makes me seem like a crazy person talking to myself :p

    /thread! :)
  7. gigaguy macrumors 65816

    Apr 19, 2010
    So confused, getting this same error, ;not eligible for build'. Why is the devteam involved? I'm only trying to upgrade my ipad1 FW from 4.3.1 to 4.3.3. I have not jb'd this ipad. on a Mac.

    I have jb'd another ipad1 months ago, and my Touch 4g. and I have saved blobs from my iPhone3G, Touch 4G, and previous iPad1 with TIny Umbrella and on Cydia. all on the same Mac. This ipad1 is a refurb I just got from AT&T. it set up and synched fine, just wouldn't update.

    why is just updating thru iTunes, on this new to me iPad1 erroring out?
    I gave up and just Redsnowed it and it added Cydia and it jbroke and stayed on 4.3.1.
    THe more I read about jbing the more I get confused. I've never had a device bloccked my iTunes from restoring or updating.
  8. bella92108 thread starter macrumors 68000

    Mar 1, 2006
    Read my post, edit your HOSTS file, it'll fix the issue.
  9. gigaguy macrumors 65816

    Apr 19, 2010
    but why now, never had to do that before, what causes this needing to be done, just wanting to understand.
  10. bella92108 thread starter macrumors 68000

    Mar 1, 2006
    iTunes auto-updates the hosts file, so likely either in the background or with an install of the 10.2.2 or what not it likely un-hashed the marked out line in the hosts file. I have to re-edit mine everytime I restore, and every time I freak out and post just like this to be reminded I need to mark out that line.
  11. freedevil macrumors 6502a


    Mar 7, 2007
    Same problem I hashed out the apple from /etc/hosts and it updated

    # gs.apple.com
  12. krazybboy macrumors newbie

    May 12, 2011
    Thank you so much. I have been going crazy. It fixed my problem. Thanks again. You are awesome!!!!!
  13. Seabit macrumors newbie


    May 13, 2011
    on my mac it says i don't have access to /private/etc/hosts, please help me!
  14. eastercat macrumors 68040


    Mar 3, 2008
    Are you logged in under the administrator account?

Share This Page