This is bugging me and I cant take it any more: problem with SD card...

Discussion in 'Mac Basics and Help' started by VoodooDaddy, Dec 8, 2006.

  1. VoodooDaddy macrumors 65816

    May 14, 2003
    My digital cam takes SD cards. When I first got it I KNOW for a fact I was able to shoot some pics, pop the card in the reader, transfer my pics, then delete the pics off the card while it was still in the card reader.

    The cam came with a measley 16mb card so I bought a couple 512mb cards. I KNOW for a fact the first time or two I took pics on the 512 card it worked the same way. Took pics, put card in reader, transfer, drag all pics from card to trash and delete, thereby emptying the card.

    Well somewhere along the way the card has become "read only" when in the card reader. I can transfer the pics but I cant delete them while the card is in the card reader. I have to put the card back into the camera and format the card in camera to empty it (canon powershot cam).

    So today I dug out the 16mb card it came with to see something. Put the card in the cam, took a few pics, put card in card reader, transferred pics, dragged pics from card to trash and deleted. It worked! At this point I figured it must be something with the other cards I had.

    So I swapped them in and out a few times, and then I noticed something. On the 16mb card it TOO IS NOW READ ONLY!!!! Says I do not hav sufficient priviledges to delete the card.

    Now how in the world did it go from me being able to do it 3 minutes ago to basically locking me out of the card? Is there ANY way around this??? Its really really annoying me.

    Hope this is clear enough for you to understand.
  2. garfield2002 macrumors regular

    Oct 31, 2003
    Very strange. Are you accidentally flipping that small little switch on the card? That makes it read only. You may also try re-formatting the card in the camera.

    EDIT: Ah you tried reformatting in the camera. Another idea, perhaps its a driver problem with the reader and you need an update? (Mainly for PC) Some readers do funny things with OS X. Can you replicate the problem with another reader.
  3. VoodooDaddy thread starter macrumors 65816

    May 14, 2003
    I really dont know whats going on. The 512 cards have a lock switch and Ive tried it both ways with the same result: unable to delete pics from the card while in the card reader. The 16mb card doesnt have a lock so thats no issue. But the 16mb card just went from read/write, me deleting pics off of it while in the card reader to read only right in front of my very eyes.

    Also, its a Sandisk card reader. No drivers required I dont believe is there? Just plug in and use? This never happened with a compact flash cards with our old camera.
  4. xPismo macrumors 6502a


    Nov 21, 2005
    Wow. I remember having the same problems when I borrowed a SD camera from a PC user. Same exact thing happened with mine too. I dont have a solution though, I just gave the camera back. :eek:

    I did read that Canon suggests letting the camera do all formatting/deleting of material on the cards. It allows all the maintinace functions to keep up to date.

    Maybe its a good thing that you have to allow the camera to format?
  5. VoodooDaddy thread starter macrumors 65816

    May 14, 2003
    I know. Its really a minor thing, putting the card in the camera and navigating to the format menu. But I just dont understand why its locked the card down when obviously it worked the way I wanted it to the first time.
  6. apfhex macrumors 68030


    Aug 8, 2006
    Northern California
    I don't know either, my camera uses CF cards and I always use the USB cable to transfer directly from the camera (I never take out the card) and then use iPhoto or whatever to delete the files from the card/camera. I do have a card reader, and it would be a little faster, but connecting the camera VIA USB is very reliable, and I think Canon's recommended way of doing it?
  7. kish macrumors newbie


    Nov 29, 2006
    Trinidad in the Caribbean
    Ownership & Permissions

    You can try this it may work, with the card on your Mac desktop click once on it to highlight it then get info on the card (command I or file menu/get info).

    In the window that appears you should see at the bottom “Ownership & Permissions” with a drop down menu that should say: You can “Read & Write” if it says “Read Only” click on it and change it to “Read & Write”.

    I hope this works for you let us know if it does.

Share This Page