This is kinda stupid...

Discussion in 'iOS 5 and earlier' started by petrucci666, Nov 5, 2011.

  1. petrucci666 macrumors 6502a

    Joined:
    Apr 30, 2009
    Location:
    San Francisco, CA
    #1
    I use iMessage to text my family in Europe (I live in the States) and it has been great so far since it is all intergrated. But occasional hiccups in the system or who knows what causes those messages to be sent as a text message.

    And this can get expensive when sending abroad! I type up the message, wait to see if it's a blue box that's being sent, confirm it, only to find out a few minutes later that it was sent as a text message.

    Could they not put in a little warning box saying that it is going to be sent as a text message after initially saying it was an iMessage?


    This is gonna run my bill up
     
  2. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #2
    The iMessage system waits five minutes. If the iMessage is not sent/or received within those five minutes, it gets resent as an SMS/MMS. There is an option to turn off the SMS backup send in the Message settings.
     
  3. megapopular macrumors 6502a

    Joined:
    Aug 21, 2007
    #3
    Yay!

    I'm glad somebody reads up on how to use the software instead of making a post saying "this is kinda stupid..."
     
  4. petrucci666 thread starter macrumors 6502a

    Joined:
    Apr 30, 2009
    Location:
    San Francisco, CA
    #4
    Well, the whole philosophy behind Apple is for the software to be intuitive and not require a manual in a way.

    And I'm sorry but it is stupid because it does run up the bill unnecessarily.
    It was the same with the data caps and people going over those.

    And thank you for being rude to someone that was here to seek help. That's what a forum is for, right?
     
  5. Sankersizzle macrumors 6502a

    Sankersizzle

    Joined:
    Jun 5, 2010
    Location:
    Canadadada
    #5
    It would be more stupid if the iMessage didn't get sent as a text after 5 minutes, because then people would never receive the messages at all.
     
  6. tempusfugit macrumors 65816

    Joined:
    May 21, 2009
    Location:
    Chicago
    #6
    Hence the fallback to SMS. 99% of us aren't in your situation so why shouldn't it be designed as such? At least you have the option to not fall back to SMS. Problem solved.



    I stand with the 99%.

    #OccupyThisGuysPhone
     
  7. Thetonyk123 macrumors 68000

    Thetonyk123

    Joined:
    Aug 14, 2011
    Location:
    Earth
    #7
    iPod touchs and iPads don't have this :)
     
  8. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #8
    Because their iMessage system is via email only and they can't SMS. For those devices, the message sits in Apple's servers until its sent.
     
  9. Steve28 macrumors member

    Joined:
    Jun 14, 2011
    #9
    You did look at Settings -> Messages -> send as SMS? Just turn that off.
     
  10. acfusion29 macrumors 68040

    acfusion29

    Joined:
    Nov 8, 2007
    Location:
    Toronto
    #10
    it would as soon as they connect to the internet.
     
  11. megapopular macrumors 6502a

    Joined:
    Aug 21, 2007
    #11
    What you didn't do is...

    actually ask for help! I wasn't being rude to you, just stating my opinion. Why do you think Apple makes a manual? Have you read the iPhone 5.0 manual? I ask that because you seem as if it would really be helpful for you. Even without the manual, you could have tapped on settings, then tapped on messages and saw the iMessage Send as SMS settings option. My advice for you is to at least ask if you're really looking for help... it's sad that you're confused to the point that you actually think you were asking for help when you only complained.
     
  12. srf4real macrumors 68030

    srf4real

    Joined:
    Jul 25, 2006
    Location:
    paradise beach FL
    #12
    Some of us don't know the difference between SMS/MMS.. and downloaded the manual to our iBooks, since you can't even find one to look at on a real computer.. and now it (manual) doesn't work because we jail broke and iBooks is broken. And it's kind of stupid that Apple expects everyone to "just know" how to disable the automatic text backup default settings.. I found the answer to op question very useful and op question, comments very valid in the first place. Do shebags.:cool:
     
  13. Jare macrumors 65816

    Jare

    Joined:
    Jun 17, 2010
    Location:
    Canada
    #13
    You need to read a manual to learn how to toggle a switch located in settings?
     
  14. ladytonya macrumors 6502a

    Joined:
    Oct 14, 2008
    #14
    I think it's set to send SMS/MMS as a backup by default because most of us DO want that message sent! While iMessage is handy, I personally only regularly text one person who is also using an iPhone and if he doesn't get it through iMessage, I WANT him to get the message another way! I guess if I were in the OP's situation and it ended up going international and got expensive I might be upset, but not too much because what did you do before? My guess is you probably just paid for the international text or you communicated in some other manner. Plus, I didn't need a manual, I just went through every single option under settings to see what all my options are because I am not one to just leave things status quo. Read through your settings, you never know what you might find in there! :)
     
  15. dotme macrumors 6502a

    Joined:
    Oct 18, 2011
    Location:
    Iowa
    #15
    Maybe I'm missing something, but if you want to send an iMessage internationally, wouldn't it make sense to use the recipients Apple ID if you don't want it to fail over to SMS? If the Apple ID is used, instead of phone number, I would think that should effectively prevent any chance of the message going via SMS instead. Just a guess though...
     
  16. Gav2k macrumors G3

    Gav2k

    Joined:
    Jul 24, 2009
    #16
    Wirelessly posted (Mozilla/5.0 (iPhone; CPU iPhone OS 5_0 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A334 Safari/7534.48.3)

    If your only texting family then put your phone in airplane mode and then turn wifi back on. Simple
     
  17. thewitt macrumors 68020

    thewitt

    Joined:
    Sep 13, 2011
    #17
    You are complaining because you modified your device and now you cannot run iBooks? Don't expect sympathy... Expect more Apple software to quit functioning on jail broken devices in the future.
     
  18. srf4real, Nov 6, 2011
    Last edited: Nov 6, 2011

    srf4real macrumors 68030

    srf4real

    Joined:
    Jul 25, 2006
    Location:
    paradise beach FL
    #18
    I am not complaining. You didn't detect my sarcastic tone. But I do defend the OP, point is valid and again not every person with a phone knows what the hell a sms / mms is. Old folks still call it texting. Some of us have lives, also.. and don't care about reading books, watching movies, buying records.. on our phone. Lol. As long as I can open a pdf there should be no issue, btw. That's just plain STUPIDO limiting the iOS 5 manual to iPhone/ iPad use only. Ridiculous.
     
  19. MastahRiz macrumors 6502

    Joined:
    Aug 7, 2010
    #19
    Yup- this is pretty much perfect. Only thing I wish they would change is to break it into:

    "Send as SMS" for local numbers ON/OFF
    "Send as SMS" for international numbers ON/OFF

    That way I can keep it on for locals since I have unlimited texting, but turn it off for international numbers since I don't want to pay for those to be sent as text.
     

Share This Page