This is the worst thing that could have happened

Discussion in 'macOS' started by Mattia Sullini, Oct 27, 2007.

  1. Mattia Sullini macrumors newbie

    Joined:
    Oct 27, 2007
    #1
    [solved, scroll down to EDIT]

    Heya, first time here because i just got a HUGE ptoblem with Leopard. Installed and everything went fine, then tried to connect to the computer through my MacbookPro. Wow, i said, they improved the permission rules! But i want to access the entire disk, right? Then added it to the shared documents. But i do not want other to read my volumes, let's change those preferences. Here came the problem:i clicked the wrong line and then set "no access"....but to ALL ADMINS!!!! The disk's icon then cahnged into the one that ahve folders when they are not condivided and everything then freezed....Doing the startup again causes the blue screen to appear and stay...the computer is unusable and the disk cannot be seen through network. I am trying right now to install Leopard even on my second disk and i hope i will be able to reset the permissions. Anyway... WATCH OUT! And to Apple: it would be nice to add a damned WARN message to prevent dorks like me to commit such a suicide.

    [EDIT]: That fixed the problem. But what if i hadn't got another disk on the same machine?
     
  2. Virgil-TB2 macrumors 65816

    Virgil-TB2

    Joined:
    Aug 3, 2007
    #2
    communication problem

    Given that what you are describing is kind of a communication problem on Apple's part, it's probably ironic that I (and possibly everyone else), have no idea what you are trying to say here.

    If you could describe what you did clearly, maybe someone could help you out.

    If you can't take the time to even write this post correctly, possibly you are too hasty of a person in general and should just slow down and think a bit before you move further ahead with this. :)
     
  3. Queso macrumors G4

    Joined:
    Mar 4, 2006
    #3
    You would boot from an OSX installation disk and repair permissions? ;)
     
  4. Mattia Sullini thread starter macrumors newbie

    Joined:
    Oct 27, 2007
    #4
    Ok, i calmed down a little bit now that i solved the problem. Here's what i did...clearly;)

    1- Opened system preverences
    2- Opened sharing
    3- Enabled document sharing
    4- Added my entire startup disk to the shared volumes
    5- Set the permissions for both others and admins to "no access"

    At this point the computer became obviously unusable. What remains of this thread, could be just the need of introducing a confirmation message before accepting such an input. Foolproof?:)
     

Share This Page