Apps This "now playing" red button... How do I get rid?

dinojr

macrumors member
Original poster
Mar 11, 2008
65
37
OK so this appears after playing music.. Top middle.



I keep mistaking it for the "regular" red dot for notifications...
If I stop the music I want it to go, however I cant find the option to remove it? I closed the now playing and music apps and its STILL there. :mad:

Any ideas?
 

eclipse01

macrumors 68030
May 16, 2011
2,522
271
Eau Claire, WI
I actually really like this addition into Watch OS, however I completely get what you are saying.

I don't know of any way to completely remove it but it only happens when music is playing. In other words even if the song is "paused" it shouldn't be up there.
 

dinojr

macrumors member
Original poster
Mar 11, 2008
65
37
Agreed. However it is back again today... Music is paused, "Now Playing" and "Music" Apps are closed, but there it is.
Whoever thought colouring it red and putting in the same place as notifications, was a complete idiot. :mad:
 
  • Like
Reactions: i hate phones

RyCan3

macrumors 6502a
Jun 13, 2010
528
208
I’m having the same issue. I hope it’s a bug and will go away. I had the green call notification on my watch earlier for like 10 minutes after I hung up. Made me second guess whether I hung up or not.
 

Loge

macrumors 68030
Jun 24, 2004
2,694
1,168
England
What is the point of it anyway? The music is playing on my phone, not the watch, and I know it's playing because I can hear it.
 
  • Like
Reactions: tomtattoo

dinojr

macrumors member
Original poster
Mar 11, 2008
65
37
I “think” I solved it.
To get rid of it you need to sync new music to the watch.

Then to prevent it appearing, when finished playing music click pause on the watch first... DO NOT just power down your BT headphones or the watch waits for the BT connection to return and the now playing dot appears.

So, always pause music before disconnecting your headphones, so far this has worked for me.
 

BasicGreatGuy

macrumors G5
Sep 21, 2012
12,984
12,435
In the middle of several books.
I “think” I solved it.
To get rid of it you need to sync new music to the watch.

Then to prevent it appearing, when finished playing music click pause on the watch first... DO NOT just power down your BT headphones or the watch waits for the BT connection to return and the now playing dot appears.

So, always pause music before disconnecting your headphones, so far this has worked for me.
It also happens when watching videos.
 

haruhiko

macrumors 603
Sep 29, 2009
5,096
2,753
I find it annoying too, but I have disabled the automatically launch music app function so it is necessary for me to call out the music control. I just think that if it is not red it would be much better.
 

the future

macrumors 68000
Jul 17, 2002
1,687
1,640
I “think” I solved it.
To get rid of it you need to sync new music to the watch.

Then to prevent it appearing, when finished playing music click pause on the watch first... DO NOT just power down your BT headphones or the watch waits for the BT connection to return and the now playing dot appears.

So, always pause music before disconnecting your headphones, so far this has worked for me.
Had the same problem, this solution worked for me, too.
 

dbrewood

macrumors regular
Jun 8, 2018
248
65
Manchester, UK
I “think” I solved it.
To get rid of it you need to sync new music to the watch.

Then to prevent it appearing, when finished playing music click pause on the watch first... DO NOT just power down your BT headphones or the watch waits for the BT connection to return and the now playing dot appears.

So, always pause music before disconnecting your headphones, so far this has worked for me.
No good alas if Carplay decided to turn on music automatically (seems no way to stop it) as it then triggers it on the watch.
 

Pseudo-Fed

macrumors 6502a
Jan 28, 2017
538
307
Pause music on watch before turning off headphones. If you fail to do this you can turn watch off and back on and it removes Now Playing.....
 

Bazooka-joe

macrumors 68040
Mar 12, 2012
3,144
1,426
Swindon, England
I have never seen this now playing icon. I play music on my watch from my phone and use my AirPods. When I finish playing music, I stop it via the watch and remove my AirPods.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.