'This partition cannot be modified'

Discussion in 'macOS' started by JefferyShin, Jun 11, 2010.

  1. JefferyShin macrumors regular

    JefferyShin

    Joined:
    Jun 20, 2009
    #1
    Hello, I have a 500GB WD Passport, 200GB partitioned for all my movies, etc, and 300GB partitioned for TM.

    I wanted to get rid of the TM partition. However, when I try to delete the partition, the minus arrow is greyed out, and on the side, it says 'this partition cannot be modified'.

    The only way to get rid of it is to delete my whole external HD, both partitions. However, I want to keep everything in partition 1.

    Any ideas? I've tried going to the TM partition and clicking erase.
     
  2. larkost macrumors 6502a

    Joined:
    Oct 13, 2007
    #2
    If the driver was partitioned with the FAT/BIOS partitioning system (not to be confused with the FAT volume format), then you can't alter the partition layout with Disk Utility. It has to be in GPT (EFI) format for Disk Utility to be able to live-modify things like you want.

    So you have two choices:

    1) Erase everything and re-partition the drive, possibly changing the partition format in the process.

    2) Use another tool to re-partition the drive. I believe that the GPartedLive disc can be used to boot the Mac and do this, but have not actually tried this trick with Apple hardware.
     

Share This Page