This update bricked my MacBook. Help!

Discussion in 'macOS High Sierra (10.13)' started by Jacoblee23, Sep 27, 2017.

  1. Jacoblee23 macrumors 65816

    Joined:
    Nov 10, 2011
    #1
    I have a 2017 12” MacBook. I tried to update to mac os Sierra and I lost WiFi connection in middle of the update and it messed up my MacBook and gave me the infamous question mark. I have tried to do recovery mode several times and every single time it updates I get the error message “An error occurred while preparing the installation. Try running this application again. My MacBook is bricked. What do I do? Should I download sierra to a flash drive or what do I do to get my MacBook up and running again?
     
  2. bo217 macrumors newbie

    bo217

    Joined:
    Jan 11, 2014
    Location:
    Atl, Ga
    #2
    I experienced a similar problem yesterday when I upgraded the system. This is how I addressed it.
    1. Create a bootable USB installer for High Sierra.
    2. Restart the computer –> immediately press "option"
    3. Install the system from there
     
  3. shadedred macrumors member

    Joined:
    Feb 5, 2009
    #3
    Likely what's happened is that your current partition has already been formatted to APFS during the failed High Sierra install - in that case your existing Recovery Partition will fail as it's trying to install Sierra onto an APFS volume.

    You're on the right track - download a copy of High Sierra (not Sierra) and make a bootable USB (https://www.imore.com/how-create-bootable-installer-mac-operating-system-high-sierra). Boot into that drive, and you can then use Disk Utility to erase the partition and start over with a clean install.

    I ran into something similar on Monday and this worked without issue.
     
  4. BLUEDOG314 macrumors 6502

    BLUEDOG314

    Joined:
    Dec 12, 2015
    #4
    Why not use internet recovery? command option shift R. it'll get to the 10.13 internet recovery, then you will likely have to erase the drive and then clean install.
     
  5. Jacoblee23 thread starter macrumors 65816

    Joined:
    Nov 10, 2011
    #5
    It won’t work. An error message comes up every time
    --- Post Merged, Sep 28, 2017 ---
    It won’t let me install from the external thumb drive. It says this disc doesn’t use the guid partition scheme or whatever that is and I have no idea how to fix it.
    --- Post Merged, Sep 28, 2017 ---
    Any ideas on how to fix the guid partition situation on my external so I can install High Sierra?
     
  6. shadedred macrumors member

    Joined:
    Feb 5, 2009
    #6
    Despite a successful install to High Sierra during my testing, the Recovery Partition was still on 10.12
    Were you able to launch the High Sierra Installer?
     
  7. Jacoblee23 thread starter macrumors 65816

    Joined:
    Nov 10, 2011
    #7
    Yes I won’t let me install it from external because of the guid partition scheme pronly. Might as well just return my MacBook at this point.
     
  8. shadedred macrumors member

    Joined:
    Feb 5, 2009
    #8
    Boot from the installer again - but before attempting to install High Sierra, you likely need to "erase" your existing partition first. Launch Disk Utility, click the View button (Upper Left) and choose "Show All Devices" to get a similar view as below. Click on the top-most drive (I believe it's named similarly as below: APPLE SSD...etc"), then click Erase (Center of the screen). Choose the name of the drive (Default: Macintosh HD), change the Format to APFS (Should be top option) and lastly choose GUID Partition Map as the Scheme - then hit Erase.

    You'll be prompted whether its successful or not, if successful, you can quit out of Disk Utility and proceed to "Install macOS" at the home screen of the installer. If not... let me know... there was an instance where I received an error upon trying to erase the disk.

    [​IMG]
     
  9. Jacoblee23 thread starter macrumors 65816

    Joined:
    Nov 10, 2011
    #9
    I get an error when trying to erase Apple ssd.
     
  10. Mockletoy macrumors regular

    Mockletoy

    Joined:
    Sep 26, 2017
    Location:
    Kansas City, MO
    #10
    So you boot into the USB installer and choose Disk Utility. Then you try to erase the SSD and get an error?

    What is the exact error? I have found in Sierra and High Sierra that Disk Utility can be weird at times with erasing and partitioning in that it'll start the operation and then fail because it couldn't unmount the drive it's trying to erase. Try right-clicking on the SSD and unmounting it, and then erasing it. It's worth a shot.
     
  11. Jacoblee23 thread starter macrumors 65816

    Joined:
    Nov 10, 2011
    #11
    Thank you all for your help. I finally got it all resolved. I hope this never happens to me again. It was a pain.
     
  12. Saga1234 macrumors newbie

    Joined:
    Sep 26, 2013
    #12
    Are you serious? Share how you got it resolved please...
     
  13. shadedred macrumors member

    Joined:
    Feb 5, 2009
    #13
    Glad you got it figured out - sorry I didn't get a chance to respond to that last comment.

    Saga, here's what I did (unsure if Jacob did the same): if the Disk Utility version in High Sierra was throwing an error when trying to format to APFS, I had to reload the Sierra version of Disk Utility and erase the starter disk (Macintosh HD or whatever you renamed it to) to "Mac OS Extended (Journaled)," then reloaded the High Sierra installer, you should then be able to go into the newer version of Disk Utility and erase/format to APFS - then High Sierra should install.

    I can't recall if I tried unmounting as Mockletoy suggested - but I vaguely recall not being able to. Though you may want to try that method first...
     
  14. simonelwell macrumors newbie

    Joined:
    May 18, 2012
    #14
    I had the same problem yesterday updating my wife's 12" macbook to High Sierra. The installer had made the main volume an APFS volume but it wasn't bootable (no idea why). Because it wasn't bootable I couldn't set it as the start up disk from recovery mode. Diagnostics and disk utility all came up with no errors. I didn't have the cables to power it up in target mode (my mbp uses thunderbolt whereas the macbook has usb-c)

    I created a high sierra installable thumb drive and booted from that... then installed again - which (thankfully) preserved the data as my wife's laptop wasn't backed up.

    All sorted, but 3 hours of my life I can't get back. Thanks Apple.

     

Share This Page

13 September 27, 2017