This WiFi loss thing is bad for me

Discussion in 'MacBook Pro' started by Kelly™, Jan 24, 2008.

  1. Kelly™ macrumors regular

    Joined:
    Jan 4, 2008
    #1
    So I posted a Q here a while ago and was told that OS X Leopard w/ MacBook(Pro) has problems recovering the WiFi connection after you sleep the laptop.
    [to say for those who don't know]
    Whenever I sleep my MBP and bring it back, my AirPort card just gets a self assigned IP and never regains connectivity, even if I try to renew the DHCP lease, turn it off and back on, etc.

    It seems that sometimes it does this even when I haven't slept it. I find myself rebooting quite often, which sucks because thats half the reason I left Windoze.
    (I tend to close the lid more often than most people, to carry it around or place it next to my chair when watching TV) So when you add the sleep problem plus the random, not often, just sometimes, drops on it's own, it gets on my nerves.

    Does anyone know when this will be fixed? Tips and or fixes? Does this happen to alot of you?
    Is this something the AppleStore can fix?

    Regards
     
  2. heatmiser macrumors 68020

    Joined:
    Dec 6, 2007
    #2
    Only real solution (besides moving to Tiger) is to wait for updates. 10.5.2 is rumored to fix a lot more bugs, but it's anyone's guess when that'll drop, and how much it'll actually do.
     
  3. Kelly™ thread starter macrumors regular

    Joined:
    Jan 4, 2008
    #3
    Unfortunately im tied to leopard :/
    Adobe CS4 (Beta/RCX) for mac only targets leopard. -shrugs-
    And I need it for work...
     
  4. mcvaughan macrumors 6502a

    Joined:
    Aug 9, 2007
    Location:
    Houston, TX
    #4
    There was an update that already addressed this. If you haven't installed it yet, then do so now. If you have, try wiping out any saved passwords in your Keychain regarding your AP.
     
  5. Kelly™ thread starter macrumors regular

    Joined:
    Jan 4, 2008
    #5
    Forgive me, but im oly three months into loving OS X.
    How do I wipe my keychain?
    And I run software updater, im all up to date there. Is there another updater im supposed to be running?


    This will sound dumb, but is it possible I have a virus?

    -is being glared at already by "there are no mac viruses" fanboys-
     
  6. mcvaughan macrumors 6502a

    Joined:
    Aug 9, 2007
    Location:
    Houston, TX
    #6
    You're not sounding dumb, but the probability is low.

    Your keychain is under Utilities under Applications. There you'll find Keychain Access. Go in there and look for your access point's name under the Login keychain. Highlight it and do an Edit, Delete. Then I'd go back and re-configure your wireless.

    Also, I don't know what kind of access point you have, but I had low performance and less range when I used Linksys access points. I switched to an Apple Extreme Base Station and things really improved. My range was better and I'm seeing faster speeds as well.
     
  7. Hmac macrumors 68020

    Joined:
    May 30, 2007
    Location:
    Midwest USA
    #7
    My MacBook Pro 1.4 running Leopard sits next to my Mac Pro on my desk most of the time and is always in sleep mode, usually with the lid closed (we have a cat that's attracted to the heat and like to sleep on the keyboard - she's typed some weird stuff...). I've never had the laptop fail to reconnect to my Airport Extreme when waking from sleep.
     
  8. Kelly™ thread starter macrumors regular

    Joined:
    Jan 4, 2008
    #8
    Nope.
    I am still having the problem and I cleared my keychain after making sure I was totally up to date, and I was.

    I still have problems when my MBP wakes up. And it is even more common now that it happens while I am just surfing the web.

    My other Windows computers and my Apple iPhone don't have any trouble when my MBP is having its problem so I don't think its a problem with my router.

    If I take this into the Apple store, are they going to treat me like an idiot and think im nuts?
     
  9. Neil321 macrumors 68040

    Neil321

    Joined:
    Nov 6, 2007
    Location:
    Britain, Avatar Created By Bartelby
    #9
    Kelly i have the the same problem as you, i rang apple (it probably is'nt your
    mbp at fault)they gave me a walk thru that involved deleting some cache
    files which me being stupid i didnt write down.(temporary fix)Anyway i asked about 10.5.2
    and they told me it should be addressed in the update
     
  10. HaroldC macrumors regular

    Joined:
    Jun 1, 2006
    #10
    What's interesting to me is that my fiance has a MB and I have a MBP and she has had the same difficulties that you're encountering. I've only had it happen to me once, but it happens most of the time on her MB. Both are running Leopard and fully updated btw.

    I'm hoping 10.5.2 will address these issues. Patience.......
     
  11. noodle654 macrumors 68020

    noodle654

    Joined:
    Jun 2, 2005
    Location:
    Never Ender
    #11
    The problem for me was with my router/MBP. My Mac Mini works great, my brothers/sisters MacBooks don't work well. I have a Linksys WRT300N (draft N). It is a great router, but when I used to get full reception with my MacBook in my room, I just get 1 bar on my MBP.

    I looked at my router settings and saw that my Wireless settings were under "mixed" which meant wireless B,G,N. I changed it to Wireless G and now my speed in doubled and my range is perfect. No problems. The problem just looks like the wireless N in the MBP communicating with the wireless N in my router. Big issue that I hope gets fixed with the 10.5.2 update.
     
  12. Kelly™ thread starter macrumors regular

    Joined:
    Jan 4, 2008
    #12
    I have the same router, but im not sure I want to sacrifice the ability to transfer data among my computers in my network at tremendous speeds...
     
  13. Kelly™ thread starter macrumors regular

    Joined:
    Jan 4, 2008
    #13
    So as an update.

    I changed my WRT350N (Linksys) from MIXED to G only (G being the fastest of them all minus N) and the problem is gone.
    It works like a charm, no issues coming from wake.

    I would recommend to anyone, until 10.5.2, use G only, not mixed.

    I miss N, but I can turn it on whenever im going to be doing some major transfers...
     
  14. BuzzedHornet macrumors newbie

    Joined:
    Feb 26, 2008
    #14
    Along the same Q's as the OP but a little different. Can you set the MBP to never go asleep (at least set the airport to maintain a connection?). I pick my MBP up and move around the house all the time and I do a fair amount of upload and downloads (images, media) over my wifi network at home. Having the airport disconnect each time i close the lid sucks.

    Any suggestions to turn this off?

    I have had my new MBP for under 72 hours and this is my first Mac. So take it easy on me!
     
  15. kde82.Linux macrumors newbie

    kde82.Linux

    Joined:
    Mar 19, 2008
    Location:
    in Va
    #15
    Auto Connecting After Sleep Mode

    KELLY> Never think your "nuts" for asking help, even if it the APPLE store. but I have the same problem in different way. let me explain.


    I AM ASKING FOR HELP BEFORE I WHIP AND REIMAGE MY MPB.



    ok i haved mine since Dec. and first off put OS X10. now 10.5.2.

    when I clam(AKA SLEEP) my MPB. and then open it again(this could be 2 second or three day later). everything come back up and runs just great. BUT

    the WIRELESS does not reconnected to my network or my work or any bodys. it show me them and I have the locked Router stored. but I have to go and click on the name and it connected just fine, and then I am straight for the rest of the time....BUT

    it just happen when I upped while ago. before that, it acted just fine and wok like it should.


    So Before I whip every out and start over. DO anyone have any ideas. I am open to tring anything once.


    thank you .

    PS KELLY Dont stop asking.
     

Share This Page