Those who downloaded 4.1 gm: is muffled Bluetooth actually fixed?

Discussion in 'iPhone' started by Lostsol, Sep 2, 2010.

  1. Lostsol macrumors regular

    Joined:
    Jun 20, 2010
    #1
    Gonna wait for actual 4.1 download next week but dying to know if the muffled sound issue is fixed. SJ mentioned Bluetooth fix yesterday but wasn't specific. Anybody tested to find out?
     
  2. Darth.Titan macrumors 68030

    Darth.Titan

    Joined:
    Oct 31, 2007
    Location:
    Austin, TX
    #2
    I was not aware of a "muffled bluetooth" issue. I've used all the betas of 4.1 and have never had an issue with bluetooth.
     
  3. mhdena macrumors 6502

    Joined:
    Sep 16, 2009
    #3
    You must not use bluetooth, everyone else it seems has heard the person on the other end say it sounds like the iphone user is talking under water.

    For me its intermittant, some calls ok, others not so much:mad::eek:
     
  4. frikfrak macrumors regular

    Joined:
    Sep 17, 2007
    #4
    I have the "bluetooth problem" too, intermittently. Hoping 4.1 fixes it......
     
  5. bmms8 macrumors 68020

    Joined:
    Dec 19, 2007
    #5
    i too have this problem with my plantronics 975. i hope 4.1 really does fix these issues because this is more important than prox sensor for me..
     
  6. dstedman macrumors member

    Joined:
    Jul 5, 2010
    #6
    Yes - installed 4.1 last night and my Plantronics 925 is working fine with it where as before anyone who called me could barely understand me & I'd always have to call them back. Go get it!
     
  7. frikfrak macrumors regular

    Joined:
    Sep 17, 2007
  8. Brinkman macrumors 6502

    Brinkman

    Joined:
    Jul 26, 2010
    #8
    So annoyed that A2DP isn't fully supported still.
     
  9. gr8whtd0pe macrumors 6502a

    gr8whtd0pe

    Joined:
    Feb 21, 2008
    Location:
    Belle, WV
    #9
    I can change tracks with my bluetooth headphones on my 3g...
     
  10. Brinkman macrumors 6502

    Brinkman

    Joined:
    Jul 26, 2010
    #10
    Yeah Jailbroken.
     
  11. bmwhd macrumors 6502a

    bmwhd

    Joined:
    May 22, 2008
    #11
    Yes. Confirmed on 3 different BT devices. Also, all 3 happily switching tracks now.
     
  12. gr8whtd0pe macrumors 6502a

    gr8whtd0pe

    Joined:
    Feb 21, 2008
    Location:
    Belle, WV
    #12
    no on 4.1... none for that.
     
  13. GadgetAddict macrumors 6502

    Joined:
    Jul 10, 2010
    Location:
    Brooklyn, NY
    #13
    I have a huge problem with the muffled sound of my Bluetooth headset. I have had this both with my original iP4 and a replacement I recently got. I really hope they fixed this, it is really annoying to have people complaining that they can't hear you. At first I thought it was my BT headset but now that I see more people are having this problem it is obviously an iP4 issue.
     
  14. Brinkman macrumors 6502

    Brinkman

    Joined:
    Jul 26, 2010
    #14
    If true then I'm very excited about this release!
     
  15. bmwhd macrumors 6502a

    bmwhd

    Joined:
    May 22, 2008
    #15
    There are many mysteries with Apple but this isn't one of them. Apple dev support confirmed this was fixed as of 4.1 beta 3 and dozens of devs and non-devs alike have confirmed with various headsets.

    Now BT issues like connection lost and OEM car sync may or may not be fixed but at leaset we know the garbled audio is a thing of the past.
     
  16. mhdena macrumors 6502

    Joined:
    Sep 16, 2009
    #16
    Not so fast, I called support yesterday and the guy I talked to said he was UNAWARE OF ANY BLUETOOTH PROBLEMS!!, he sent a message to the support chat site and 1 guy confirmed the muffled sound issues. When I asked guy 1 if he used a bluetooth he admitted he did not.

    So as you see 75-80% of the people driving around (or more) with phones held to their ears, its probably the same 80% plus of iphone users holding phones to ears never using bluetooths to know of the problem.
     
  17. sinsin07 macrumors 68030

    Joined:
    Mar 28, 2009
    #17
    It would be interesting to know if this is model specific problem relating to the muffled sound.
     
  18. iUser4Lyfe macrumors 6502

    Joined:
    Jun 15, 2009
    #18
    I just use my PS3 Bluetooth and I've never had this muffled issue.
     
  19. MisterDisney macrumors 6502a

    Joined:
    Jun 20, 2010
    #19
    Sounds like 4.1 fixes a lot of problems I've never experienced. Wonder if it's even worth it for me.
     
  20. bmwhd macrumors 6502a

    bmwhd

    Joined:
    May 22, 2008
    #20
    I opened and helped resolve this bug with Apple. It would have been an issue with any BT headset that has active echo cancellation.
     
  21. sailmac macrumors 6502

    sailmac

    Joined:
    Jan 15, 2008
    #21
    Thanks for that specific bit of info.

    I've been experiencing the problem intermittently with iP4 and a Jawbone ICON. I look forward to installing 4.1 for the fix.

    I hope 4.1 also resolves a problem with text-to-speech instructions sent by MobileNavigator 1.6 to the BT headset (utilizing A2DP)...

    ... If the instruction is spoken via the iP4's built-in speaker, you get a full sentence such as, "In one mile at the T junction turn right onto First Street."

    But when the instruction is announced over bluetooth the first several syllables are cut off. All I hear is, "…tion turn right on First Street."

    If not fixed by iOS 4.1, then perhaps I'll cast the blame on Navigon? :confused:
     
  22. Gathomblipoob macrumors 68040

    Gathomblipoob

    Joined:
    Mar 18, 2009
    #22
    I noticed the very same problem with Bluetooth and Navigon. Glad I'm not alone!
     
  23. sailmac macrumors 6502

    sailmac

    Joined:
    Jan 15, 2008
    #23
    BT+MobileNavigator problem remains

    Bummer. I upgraded to 4.1 and tested. The BT+MobileNavigator problem is not fixed. I'll send the bug info to Navigon, and maybe open a new thread about it here at MR.
     
  24. IrishVixen macrumors 68020

    IrishVixen

    Joined:
    Jun 20, 2010
    #24
    I don't think the BT/Navigon bug isn't a universal one. I'm still on 4.0 on an iPhone 4, using a Motorola T505, and while I've had both the muffling and an echo issue, I've never had it cut off any of Navigon's instructions. That makes me think it may be partly a compatibility issue with your BT device. Be sure to let the Navigon folks know what hardware you're using if you report it.
     
  25. joudbren macrumors regular

    Joined:
    Apr 13, 2007
    Location:
    Edmonton, Alberta, Canada
    #25
    Could be some truth to this. I've never had an issue with my Motorola T505 either with Navigon and iPhone4 and recently I switched to the new Blueant S4 and I'm getting the cutoff as well. I also had a Jabra 700 that cutoff the first bit of the Navigon audio commands too. Something is definitely different with the T505 as it seems to work ok.

    I called Blueant and they've never heard of this problem. I told them I would wait for the 4.1 firmware upgrade to see if the problem was fixed but it isn't so hopefully Navigon can come up with a fix or maybe Blueant in my case. I'm loving the S4 otherwise so fingers are crossed. Cheers!

    James
     

Share This Page