Three beeps on startup

Discussion in 'MacBook Pro' started by brainwave89, May 20, 2011.

  1. brainwave89 macrumors 6502

    Jul 7, 2006
    I a month old MBP with a bto SSD. When I removed the SSD drive and placed a SATA drive that is NTFS formatted I hear three beeps and the screen stays frozen. I cannot boot from my Snow Leopard DVD.

    I want to use the 320GB SATA drive when I need more space than the SSD drive. What is causing my inability to boot from the Snow Leopard disc?

    Thank you for looking?
  2. imaketouchtheme macrumors 65816

    Dec 5, 2007
    The consecutive beeps has to do with the RAM either being bad or seated incorrectly.

    Try reseating both sticks or testing one at a time to see which one, if any, is bad.
  3. brainwave89 thread starter macrumors 6502

    Jul 7, 2006
    Thank you imaketouchtheme.

    The beeps only occur when I insert the SATA drive and restart the computer. When I replace it with the SSD drive it boots w/o any beeps. I've inserted the SATA drive at least on three separate occasions.

    This would suggest that the RAM is not the issue.
  4. imaketouchtheme macrumors 65816

    Dec 5, 2007
    Then are you sure it's three beeps? The reason I ask is that error code only refers to the memory being seated improperly and/or being bad.
  5. brainwave89 thread starter macrumors 6502

    Jul 7, 2006

    I read about it associating the three beeps to RAM issues but it doesn't apply in my case.

    It's got me puzzled.
  6. imaketouchtheme macrumors 65816

    Dec 5, 2007
    Yes. That does not make any sense whatsoever.

    I'm out of ideas as there are no more.
  7. DewGuy1999 macrumors 68040


    Jan 25, 2009
    Could it be caused by the SATA drive being NTFS formatted?
  8. daneoni macrumors G4


    Mar 24, 2006
    Still doesn't hurt to try it.
  9. datumax macrumors newbie


    Feb 24, 2011
    Similar: MBP & three beeps after SSD/SL install

    I had MicroCenter install the drive without issue using a OWC DataDoubler in the optical bay. I know the newer MBPs have a 6GBPS controller for the optical bay but my SSD--a 128GB Kingston V100+ (SNVP325S2128GB)--is 3 GBPS so it wouldn't make a difference. Besides, I wanted to keep the SMS for my 750GB WD HD.

    The SSD is readable and writeable in Snow Leopard (10.6.7), booted from my standard HD. The only way I could install OS X on it was via Target Disk Mode using my wife's 2008 MBP, which completed without error.

    I have tried holding the Option key on startup and selecting the SSD, as well as booting into the standard HD installation and setting the SSD as the Startup Disk in System Preferences. Neither works.

    The SSD was formatted with one Mac OS Extended (Journaled) GUID partition.

    I have tried resetting PRAM and NVRAM to no avail. I have also tried resetting SMC.

    Any ideas?:confused:
  10. GGJstudios macrumors Westmere


    May 16, 2008
  11. datumax macrumors newbie


    Feb 24, 2011
    RAM is good.

    I have read the article on beeps, indicating 3 beeps = RAM issue. I reseated the RAM and it made no difference. The system works fine when booted via standard HD and both DIMMs are detected in About This Mac, for a total of 8 GB.
  12. Naimfan macrumors 601


    Jan 15, 2003
    Well, since the system boots fine with the SSD, the problem is with the SATA NTFS hard drive. Have you tried reformatting it?
  13. GGJstudios, Jun 13, 2011
    Last edited: Jun 13, 2011

    GGJstudios macrumors Westmere


    May 16, 2008
    If you're using the SATA drive as your internal drive, it must be formatted HFS+ (Mac OS Extended).
  14. Macmani7 macrumors newbie

    Jun 13, 2011
    I believe NTFS isn't supported by OSX? When you put in the OS disc when you restart hold the option or C key when rebooting it will take a little time bc it loads onto ram and not HD once the setup comes up find the disk utility and select the HD erase it with format journaled or extended journaled that SHOULD solve your problem because if the ram wasn't working properly you couldnt run with SSD
  15. alexmarthin macrumors newbie

    Aug 15, 2011
    Hey brainwave89

    Did you solve your problem?
    I'm having the exact same issue.

    No faulty RAM and 3 beeps when I boot from Snow Leopard DVD.

    Feeling a bit stuck.
  16. kristoffer.engh macrumors newbie

    Sep 15, 2011
    Is the problem solved?


    I have the exact same problem.

    Its a brand new MBP with 8 gb and Vertex SSD. When its connected, I hear 3 beeps. Is the disk damaged? It works only with the original disk. No memory problem.

    Best Regards
    Kristoffer Engh
  17. willko747 macrumors newbie


    Dec 24, 2011
    I got mine finally working


    Had the same problem (using a Vertex III like kristoffer.engh).
    However I had an external HDD with a Time Machine backup of my first hard drive on it (the process should probably work the same for install CD though).

    Problem Root:
    The new drive was not formatted to Extended Journaled.

    1.) I loaded to ram upon booting (by holding option key).

    2.) Held option-key down as i clicked on my drive where Time Machine Backup
    was. (at this point you can click the install CD while holding option

    3.) Used Disk Utility to erase and format my new drive to Extended Journaled.

    4.) Closed Disk Utility.

    5.) Install OSX from menu.

    6.) Done

    My Time Machine backup size was too big for me to restore onto my new drive, but It did have OSX Lion Install option so I went with that.
    Hope this helps some of you out there having the same problem.

Share This Page