Three problems I have on my MBA+Mavericks

Discussion in 'OS X Mavericks (10.9)' started by realpras, Oct 6, 2013.

  1. realpras, Oct 6, 2013
    Last edited: Oct 6, 2013

    realpras macrumors regular

    realpras

    Joined:
    Oct 6, 2013
    #1
    Hi guys, I have two questions regarding my Macbook Air 2012 running Mavericks GM:

    1. I have a problem with my Maps on Mavericks.
    I can open it just fine, no crash or whatever but the map itself just won't load, whatever mode it is on. Here is the screenshot of my Maps:

    Screen Shot 2013-10-07 at 9.56.13 am.png

    As you can see, it just stays blank all the time.
    I remember though that it worked previously on the DPs (although I can't remember which DP I tried it on), but never opened it again since then.

    Any idea?


    2. The second problem occurs on both Safari and Chrome.
    If I type something, for example in Google search field, then highlight it to retype something else, instead of typing it straight away, I have to click my cursor on the field and press delete key first, otherwise the highlighter will stick on the first letter and thus I can't type past the first letter.

    Screen Shot 2013-10-07 at 10.11.44 am.png

    I hope I explain it quite well and the picture helps. Does this occur to you?
    What interesting is it doesn't happen with Firefox.
    And since Chrome and Safari use the same Webkit engine, I suspect there's something wrong with that.


    3. I can't use the command+E to eject external disk anymore, I have to right-click it and click "eject <name>" to eject. I used to be able to do it though. However, the shortcut works if I use my Guest Account. What gives?

    Just for more info, the second and third problem have been occurring since Mountain Lion, but not since the very first beginning.
    It just happened recently and I hope with the installation of Mavericks it would solve the problems but it apparently didn't.
    And I regularly clean my mac's caches using CleanMyMac2, except the Safari cache folder. Does it probably affect the functionality of my Maps and Safari/Chrome?


    Thank you for your help, and if any of you don't really quite get the second problem I'll try to rephrase it better :)
    *I hope you will all know what I mean though*
     
  2. blitzwing macrumors member

    Joined:
    Sep 30, 2012
    #2
    I am using the 2011 MBA with Mavericks GM.
    I did an upgrade and not a brand new installation.

    I don't have and can't replicate the first 2 problems you have. My maps is working fine and the highlighting of text and typing over it works on my Safari.

    I don't have an external drive now to test your 3rd problem. Hope it helps!
     
  3. realpras thread starter macrumors regular

    realpras

    Joined:
    Oct 6, 2013
    #3
    I did an upgrade too from DP8. I asked my friends as well but they also didn't have these problems. I hope someone can help me fix this :(
     
  4. pickaxe macrumors 6502a

    Joined:
    Nov 29, 2012
    #4
    MBA 2013 on GM - all 3 features worked fine. It is more of an isolated problem.
     
  5. realpras thread starter macrumors regular

    realpras

    Joined:
    Oct 6, 2013
    #5
    any idea as of why these problems occur to mine? :S
     
  6. realpras thread starter macrumors regular

    realpras

    Joined:
    Oct 6, 2013
    #6
    Problem #2 SOLVED:

    Those of you who have similar problem, you should just un-tick and re-tick every options on the Trackpad menu in Sys Pref. It works for me, know it's not stuck on the first letter anymore. Weird.
     

Share This Page