Three WDs all not working???

Discussion in 'Mac Accessories' started by mntentman, Dec 22, 2010.

  1. mntentman macrumors regular

    Joined:
    Jan 15, 2007
    #1
    I am all of a sudden having issues with three WD drives, all are My Books (two Essential Editions, one Home Edition). The Essential Editions have light rings on the front and the Home Edition has the vertical light. The problem is that the lights on all three flash when connnected to power and are not recognized by Mac, nor do the drives start spinning. After trying every fix I could think of, I talked to WD technical support, which suggested the same things I had already done, and concluded "there seems to be a problem." Well, yes, I knew that. So I come here to see if anyone can figure out this puzzle.

    Not sure what all information will be pertinent, so I will give it all. I have been moving to a new Mac. One of these drives I used on the new Mac to transfer data. The other two were not ever connected to it but worked fine on the old Mac.

    When I tried plugging one drive in this morning, I got the flashing light and Mac wouldn't recognize drive. Same on the others, including the one that had been used before on this computer.

    I tried changing power cords... the lights continued to flash, but at a slower speed. Not sure what that means.

    I tried changing computers, same deal.. not recognized.

    I have one other My Book that works fine. I tried its power cord on the non-responsive drives and no change.

    We have had no power surges or similar problems that I know of.

    So, I have switched power cords and computers, I have tried various outlets. Nothing seems to matter.

    These couldn't have just all failed at the same time, right?

    If they have not failed, how can I get them to work? If they have failed, what the heck could have caused it?

    Am I missing something I can try? Any advice out there? Thank you!
     
  2. Hellhammer Moderator

    Hellhammer

    Staff Member

    Joined:
    Dec 10, 2008
    Location:
    Finland
    #2
    Quite hard to say. Can you open them and try the HD with a different enclosure? Maybe the enclosure is broken
     
  3. mntentman thread starter macrumors regular

    Joined:
    Jan 15, 2007
    #3
    Thanks for the comment, but no, the enclosure is not broken. Maybe it would be possible that one could great broken, but certainly not all three at the same time.

    No other ideas out there? Please...
     
  4. Fishrrman macrumors G3

    Joined:
    Feb 20, 2009
    #4
    "Thanks for the comment, but no, the enclosure is not broken."

    You're being presumptuous.

    Hellhammer was right: the enclosure/controller card may very well have some kind of problems.

    The only way you're ever going to be able to ascertain whether the problems are with the drives, or with the enclosures, is to literally take them apart so that you can try the drives withOUT the enclosures.

    I would recommend that you spend $20 and get yourself a USB/SATA dock (amazon is a good place to find them).

    You may find that once you remove a drive from the WD enclosure, and put it into the USB/SATA dock, that it may mysteriously "revive".....
     
  5. mntentman thread starter macrumors regular

    Joined:
    Jan 15, 2007
    #5
    I apologize. I was taking the term "enclosure" too literally. Yes, I think the enclosure/controller cards may have problems. And in fact I ordered a dock yesterday from Amazon, pulled one of the hard drives and am readty to test it when the unit arrives today. We'll see what happens.
     

Share This Page