thunderbolt-connected drive not spinning down

Discussion in 'iMac' started by fisherking, Apr 16, 2019.

  1. fisherking macrumors 604

    fisherking

    Joined:
    Jul 16, 2010
    Location:
    ny somewhere
    #1
    for anyone who saw my other post... i could not get my new g-drive mobile drive to mount on my 2019 imac (in the thunderbolt port). i finally got it working by resetting the SMC. and now... it works. but never stops.

    it's light flashes when my mac sleeps, and it continues to spin.

    i have 'prevent computer from sleeping...' and 'enable power nap' unchecked in energy saver (i don't use time machine). 'put hard disks to sleep' is checked...

    any thoughts, suggestions? frustating to think that the drive is always spinning...
     
  2. SaSaSushi macrumors 601

    SaSaSushi

    Joined:
    Aug 8, 2007
    Location:
    Takamatsu, Japan
    #2
    You got the drive to be recognized again with an SMC reset but have you tried an NVRAM reset?
     
  3. fisherking, Apr 16, 2019
    Last edited: Apr 16, 2019

    fisherking thread starter macrumors 604

    fisherking

    Joined:
    Jul 16, 2010
    Location:
    ny somewhere
    #3
    will try that (and report back)...

    EDIT: no change. frustrating. emailed g-tech support (and will torture apple as well soon)...
     
  4. Fishrrman macrumors P6

    Fishrrman

    Joined:
    Feb 20, 2009
    #4
    Download the free app "Semulov":
    https://www.kainjow.com

    It puts a menu icon (right side) that allows you to mount/unmount volumes as you wish.
    If you don't want the tbolt drive spinning, try DISmounting it, and see if it "spins down".

    When you need to access it, just mount it from the menu bar.
     
  5. fisherking, Apr 16, 2019
    Last edited: Apr 16, 2019

    fisherking thread starter macrumors 604

    fisherking

    Joined:
    Jul 16, 2010
    Location:
    ny somewhere
    #5
    i tried mountain, i'll try semulov, thanks. but seems the drive will spin even if ejected, and the imac is sleeping....

    here's WD's response (which is useless for my needs):

    Our drives are not meant to be put to sleep. They are working drives and we often recommend not using sleep mode on your computer once you start using external drives and put hard disks to sleep when possible should always be unchecked.

    But if you want to continue your method of using the drive that’s fine but don’t expect the G-Drive to go to sleep.

    EDIT: as long as the drive is connected, it spins. even unmounted. so, will replace it with a more practical drive...o_O
     
  6. dcpmark macrumors 6502a

    Joined:
    Oct 20, 2009
    #6
    Not sure if this helps, but my Thunderbolt enclosure (Thunderbay 4) sleeps whenever my 2019 iMac sleeps, and thus all 3 hard drives stop spinning (1 is an SSD). No issues or problems, and the manual says this is planned behavior.
     
  7. fisherking thread starter macrumors 604

    fisherking

    Joined:
    Jul 16, 2010
    Location:
    ny somewhere
    #7
    the g-drive is designed to not sleep, and does that well. have already replaced it with a seagate...
     
  8. DeltaMac macrumors G3

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #8
    Why not just disconnect the drive when you are not using it?
     
  9. fisherking thread starter macrumors 604

    fisherking

    Joined:
    Jul 16, 2010
    Location:
    ny somewhere
    #9
    the whole idea is to have a setup with minimal fuss; i like that my seagate drives sleep when my mac sleeps. nothing to (remember) to eject, or unplug. am good!
     

Share This Page

8 April 16, 2019