Thunderbolt Display not working with Sierra

Discussion in 'macOS Sierra (10.12)' started by Mobster1983, Sep 30, 2016.

  1. Mobster1983 macrumors 6502a

    Joined:
    Sep 8, 2011
    #1
    I have been using the Sierra beta and for the last couple months my Thunderbolt Display has been having issues. It turns off randomly and required a restart. Eventually it stopped working at all. Did all the normal stuff, power cycle, reset, SMC reset, etc. No fix. Both a 2013 iMac and 2011 MBA with the same issue.

    Took Display into Apple and they replaced the power node, thunderbolt cable, and the motherboard. Cost me a pretty penny. Get home and the Display doesn't work at all. Been messing with it a few days and nothing.

    Today, I sent my MBA back to El Capitan due to a school program I needed to run. On a whim, I plugged in my Thunderbolt Display and viola!! It works.

    Problem is, it won't work on my iMac with Sierra. I plan to go into Apple Store tomorrow for another reason, but wanted to bring this up here.

    Anyone else have issues with TB a Display in Sierra? I'm pretty pissed I dropped over $300 fixing a 5 year old Display when it seems to be a software issue.
     
  2. sharonoldman macrumors newbie

    Joined:
    Dec 28, 2016
    #2
    I have had problems with the Thunderbolt display with Sierra and El Capitan. Whenever I do a reboot, the problems begin again. What I do now is the following: unplug the display from the wall and the MAC. Wait a few minutes. Then plug in the wall, and then into the MAC. The display will work, but turns off after about 10 seconds. I then repeat the process. Same thing happens. But the third time I do it, it seems to work. Very strange. I also let the MAC fall to sleep on it's own.
     

Share This Page