Thunderbolt Display stuck white pixel

Discussion in 'Mac Accessories' started by Tinus, Sep 9, 2017.

  1. Tinus macrumors newbie

    Joined:
    Nov 2, 2014
    Location:
    Rosmalen
    #1
    Luckily it disappeared again because I get obsessed with these kind of things. Can't help it.

    Should I contact Apple if it returns? Or isn't it worth the hassle.

    See the pics below:

    [​IMG]

    [​IMG]

    Just curious about the different opinions regarding such issues.
     
  2. Tinus, Sep 10, 2017
    Last edited: Sep 10, 2017

    Tinus thread starter macrumors newbie

    Joined:
    Nov 2, 2014
    Location:
    Rosmalen
    #2
    And it's back :(

    Update
    Seems to be gone again. Became a lot more white pixels. But it's weird because when I did windows overview the pixels moved along with the window miniatures. So maybe it is Software related somehow. Never seen anything like this. And of course dead or stuck pixels cannot move by selecting window view. So weird.
     
  3. Acronyc macrumors 6502a

    Joined:
    Jan 24, 2011
    #3
    Do you have another Mac to plug in to see if it is a software or hardware issue with your Mac? Or maybe try booting from an external drive to see if the problem persists. It could help you rule out a software issue or something with your display.
     
  4. Tinus thread starter macrumors newbie

    Joined:
    Nov 2, 2014
    Location:
    Rosmalen
    #4
    It is gone for now. We have an Imac downstairs and another MBP. If it returns I will try that out. Seems like a software issue tho since the pixels where not stuck in place and it didn't look like artifacts from a defective GPU. Thanks for the reply and advice tho.
     
  5. Fishrrman macrumors P6

    Fishrrman

    Joined:
    Feb 20, 2009
    #5
    One pixel, don't worry about it.

    The Thunderbolt display -- that's discontinued by Apple now, right?
    And yours is almost certainly out-of-warranty, right?
    Do they still even service them?

    How much would you be willing to pay... to fix ONE PIXEL?
     
  6. Tinus thread starter macrumors newbie

    Joined:
    Nov 2, 2014
    Location:
    Rosmalen
    #6
    It was more than one. Title is wrong. Was a whole group later. But strange thing is they weren't stuck or dead. But they are gone for now. And hopefully stay gone. Probably a strange Software issue.
     

Share This Page

5 September 9, 2017